Jump to content

Mods won't download or update

Recommended Posts

In the mods folder, I appear to have correct permissions, I can delete and add new files at will. However files will not update or download from the workshop. I have tried entering safe mode, and reinstalling the game (using both steam and deleting all the folders). Nothing has worked so far. If there is a known fix I would love to be informed.

Steam downloads workshop items for other games and can even download DST mods when I set up a dedicated server on the same computer, yet they refuse to download for client DST and DS. Steam says it downloads all the mods but when I get in game it says that they're downloading. Then it goes away, like it gave up for a moment, before starting the download again... Upon further investigation I noticed that this occurs for both DS and DST. This also happens on another computer in my house with a fresh install of steam....

I've reinstalled the game 4 times now and can't figure out what the problem is...


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...