Jump to content

Seaworthy Crash

Recommended Posts

My only SW/ROG linked world keeps crashing now. It happened twice -- when I reload the game I end up on the other side and everything is fine -- this only happens when I go through the seaworthy. Now this third time it no longer loads at all and crashes the game every time (no error page, just closes). Then when I reload the game, it wants to say that mods may be the issue. It turns off all the mods, still doesn't work. I load an older non-SW/ROG linked worked with all the mods on and it's just fine.

Link to comment
Share on other sites

Do you have a lot of other documents open?

ex: you have SW open, but also have stuff like messenger or other games open

This might be why.

It happened to me too and I closed all my other windows then it stopped.

idk it worked for me I hope it works for you too.

Link to comment
Share on other sites

Someone told me it may have to do with SW/ROG worlds linked that have more than two caves open.

Well I still have that world that won't load but I started a new one a while ago and I'm at the same point a little over 1k days (only one cave open this time). Everything was fine until today when I got my first seaworthy crash. The game just closed when I went through seaworthy. Again, when I reload the game, everything is fine and I am on the other side (SW). Now I worry about it happening a 2nd and 3rd time and the whole save will be unable to load.

Link to comment
Share on other sites

So I was on day 342 and had put tons of time into this game when it started crashing and now when I try to load my game back I get a blue screen that says:                          WARNING! 
scripts/prefabs/shipwrecked.lua:503: attempt to call method 'Tropical' (a nil value) LUA ERROR stack traceback: scripts/prefabs/shipwrecked.lua:528 in (field) fn (Lua) <506-578)> scripts/mainfunctions.lua:129 in () ? (Lua) <118-149> =[C]:-1 in (method) SpawnPrefab (C) <-1--1> scripts/mainfunctions.lua:166 in (global) SpawnPrefab (Lua) <160-170> scripts/gamelogic.lua:498 in (global) PopulateWorld (Lua) <398-909> scripts/gamelogic/lua:1040 in (global) DoInitGame (Lua) <949-1231> scripts/gamelogic/lua:1285 in (upvalue) cb (Lua) <1281-1286> scripts/saveindex.lua:832 in () ? (Lua) <744-833>
Does this just mean all of the time and effort I put into this game is just wasted or is there a way to fix this. I put a seriously decent amount of hours into this game and if this bug just stole all of that progress from me I can't say I'll ever play this again which sucks because I genuinely enjoyed this game and don't want it to be ruined because of some bug. Anyways, I would really appreciate some kind of reply if possible. Thanks, I really hope this gets fixed so it doesn't just ruin this game for people. 

dont starve.jpg

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...