[Bugs Report]: Graphics & Several Gameplay Bugs


Recommended Posts

Platform: Desktop Mac

Do I use mods?: Yes, one-->Minimap HUD

Version Number: Rev. 162633

Graphic Misspellings: "Wildbore" and "Wild Bore" - It is two words & is spelled "Wild Boar". Also, when you click on their huts, it states: "What a boring house." If you want to play on the name, you could spell it, "boar-ing" house. But you really need to change the spelling of the wild pig to the correct spelling: "boar". Also note that, the spelling when you examine the pig's heads on the stakes around Touchstones have this error too.

[I'm a freelance proofreader so I notice these things. ;) (I'm the one that caught the "conscious" misspelling in DS: Together & let you know on Twitter) And, yes, you fixed that! Glad I could help - these are such great games.]

Graphic/Gameplay bug #1: Icon to make electrical doodads in Science menu isn't green showing that I have what I need to make the doodads (when I DO). I noticed a couple of other examples of this but didn't write them down. Will do, then report to you again.

Gameplay bug #2: Found a slot machine, put in coins, worked fine two times but then on the third go, I got three gold nugget icons and no pay-out. Nothing came out of the slot machine. :(

Gameplay bug#3: Items are disappearing in my inventory. So far, I've had sand, bone shards, palm leaves disappear from my inventory.

Steps to reproduce: Gather sand, bone shards and pick up palm leaves then walk or ride back to camp.

Describe your issue: I usually have visited an island, retrieved the above items & sail back to my camp on another island. By the time I get there to use the machine to craft, these items are gone and I think I've lost my mind. lol Most times, I am not attacked in the water on the way back, sometimes I do hit a wave or two. Not sure if that has anything to do with it. I have lost items in my inventory from one end of an island to the other, however, so the disappearances are not restricted to a boat trip.

Gameplay bug #4: Wild Boars aggro you when you feed them berries rather than just walk away. :( I fed a berry to a Wild Boar to acquire manure, he aggro'd me & wouldn't leave me alone, kept attacking me.

Gameplay bug #5: I notice when I put half-spoiling food (not spoiled yet), into crockpot to make meatballs, I'm getting fertilizer. I'm sure that's not what's supposed to happen. It's happened with crabs, crabmeat, carrots, berries - they are either orange (halfway spoiled) or red (almost spoiled) & I put them in the crockpot to make a meal & everything turns into fertilizer. Please note, this happens intermittently and even if only 1 out of the 4 items required is 3/4 or 1/2-way spoiling and the rest are fresh. :(  

Thanks!! Btw, LOVE the graphics of this game, the whole color scheme is terrific. Well done!




Link to comment
Share on other sites

#4 isn't a bug.  Wild boars are territorial and will attack if you stand near them.

Something like #5 was happening even with 100% fresh ingredients.  What was happening was food on the crockpot was scheduling a time to spoil but not cancelling the schedule when harvested, and then new food cooked on the same crockpot would spoil when the scheduled time arrived.  That bug was fixed in the latest patch; did you see food spoil prematurely after the last patch, or before?

Link to comment
Share on other sites

12 hours ago, Laconia2 said:

Gameplay bug #2: Found a slot machine, put in coins, worked fine two times but then on the third go, I got three gold nugget icons and no pay-out. Nothing came out of the slot machine. :(

I have had this happen too, and I think I figured out the problem: The machine was trying to give you a chilled amulet by spawning the prefab "chilledamulet", but according to the wiki, the prefab is actually called "blueamulet", so the game could not find an entity to spawn.

I reported this a week ago in a topic with a huge list of other bugs, none of this got fixed so far and I do suspect nobody even took notice. :???:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.