[Gameplay] - Console Command Causes Force Close


AlphaKennyBody

Recommended Posts

Bug Submission:

Category: Gameplay

Issue Title: Console Command Causes Force Close

Issue Description: Anytime I would simply use

c_give("prefab",#) ie: c_give("log",20)

I can enter it once... and it'll be fine no problem I'll get it into inventory and we're set to go. However, if I were to use the command again... It'll force close and just quit the game bringing me to my desktop.

I can use any item... any amount the 1st time and it'll work (I'm host). If I attempt to spawn ANYTHING after I used the c_give command 1 time already it'll just close the game.

Funny thing is works like a Champ 6/2/15. I logged on 6/3/15 and the issue started. I've tried new servers and same results.

I can use the c_spawn command and it'll work over and over but clicking on a screen let say for 40 twigs and 40 rocks and whatever will suck LOL.

Let me know what steps I can do or if something changed in a recent update.

Steps to Reproduce: c_give("prefab",#) ie: c_give("log",20)

Press ` type/paste c_give("log",20)

Press Enter

Press ` type/paste c_give("log",20) again.

And DST will freeze and close the game.

I views the DST log. It'll show the last 20 logs to be placed in inventory and that's ends the log with no crash report or error.

Link to comment
Share on other sites

Yeah, I experienced very same thing like this!

 

I actually have ran dedicated server for my friends which have been just fine until yesterday.

 

Even multiple c_give commands worked just fine.

 

But I used c_give command for me to get a hambat and press up arrow butten to repeat once more to get a marble armor this time, boom.

 

My dedicated server crashed without any error messages,

 

So I tried to host the server directly and tried to use same commands in a row.

 

The game crashed..

 

I don't know what just happened

 

may it do something with the latest patch?

Link to comment
Share on other sites

This is odd. I tried replicating this but I can't.

 

I tried as admin of dedicated server and as host:

1) Write c_give("meat",20) on console

1d) Pressed ctrl for remote

2) Press enter to do command

(I received 20 meat on myself)

3) Press the up key to get the c_give again

4) Repeat 20 times

 

No crashes. I'm missing something?

Link to comment
Share on other sites

@DarkXero, It's a bit unreliable. On a local server, I was able to replicate this by giving myself a few bernies, then 40 logs, then 40 dragonpies-- the dragonpies crashed. Nothing helpful in the logs, it cut off after giving the first dragonpie. 

Link to comment
Share on other sites

I managed to replicate it giving myself dragonpies.

 

The culprit is this line of c_give:

SetDebugEntity(inst)

My guess is that this happens because when switching items, something strange happens when you select an entity item that is in LIMBO (inventory).

 

And it appears I was right, since when investigating, the update was pushed and now we have:

function SetDebugEntity(inst)    if debug_entity ~= nil and debug_entity:IsValid() then        debug_entity.entity:SetSelected(false)    end    if inst ~= nil and inst:IsValid() then        debug_entity = inst        inst.entity:SetSelected(true)    else        debug_entity = nil    endend

That checks the entity to be valid.

 

This is now fixed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.