Setting up dedicated server, can't ping it locally :/


Recommended Posts

Hi there,

 

I'm currently trying to make a dedicated server, with the windows + steam method.

All work fine when I declare it as a LAN server, I can reach it etc... But I have issues on putting it online. I don't see / reach it by myself, and friends can't see / join it too.

 

I configured my router ( french "freebox revolution" ) to allow port forwarding.  ( tcp + udp )

I tryed to change the server port to 10998 too. ( and reforwarding port again.. of course )

 

So I'm trying to validate step by step where it can fail.

 

The first thing I tryed is installing telnet and trying to ping it localy :

 

telnet 127.0.0.1 10998

 

Here telnet tells me that I can't make a conection to this, wich seams to be a first big issue. So I was wondering, in your dedicated server, are you able to ping it ? 

My server is Notsu's World, and correctly appears on http://my.jacklul.com/dstservers/ , can someone try to connect to it and confirm me it's unreachable ( as a double check to my friend's try)

 

I can see in server start process this warning line : 

[Warning] Could not confirm port 10998 is open in the firewall. 

 

Can it be part of the issue ? I checked my windows firewall and it's ok ( udp + tcp )

 

Thx !

Link to comment
Share on other sites

hmm well the only thing you need to do to make any server communicable to the outside WAN is correctly forward the port the server software is using to the correct LAN IP address via the router config.

 

You could drop the Windows firewall temporarily to confirm that's not blocking it, but I would somewhat assume it's an issue of forwarding the right port to the right LAN IP only

Link to comment
Share on other sites

Far as I know you should always be able to use telnet to any specific port locally, so if that doesn't work I guess the server isn't actually running on that port or something is still blocking it.

 

Oh, potentially the server isn't glomming onto all IP addresses, so 127.0.0.1 wouldn't work- try the LAN IP instead

Link to comment
Share on other sites

I can ping perfctly my web server on port 80 with this : telnet 127.0.0.1 80 , so I think it works. 

The best way to check is that a windows / steam user try to ping it with telnet and telll me if it works. Maybe the server is configured to don't replay to ping, I don't know in fact. 

Link to comment
Share on other sites

i was having a issue like that  Try to open the ports in windows firewall advanced setting add a new rule  i did both inbound and outbound rules  told it to open port 10998   if i tried to open the ports in a range like it says in the example where u are adding the port numbers like 10998-10999 it doesn't work so i had to make 2 rules one for 10998 and 10999  and it works in the log says ports are open.  

 

the trouble im having now is i cant find server in the list like i could last night  when i run the server.exe from the folder it only goes to the default settings folder on 10999 and that seems to stop you from seeing it so i change the  client dst launch options to use the custom folder with port 10998 and it did show once in the server but it had ??? for the ping and wasnt able to connect

 

 It worked last night  great some people had 50-70 ping but today i have  been at it for 5 hrs and only saw it that once.... i just don't understand 

 

 Hope this helps

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.