[General] - Mods menu crashes the game quite often on updates


outseeker

Recommended Posts

Bug Submission:

Category: General
Issue Title: Mods menu crashes the game quite often on updates
Issue Description: My game hard closes itself quite often while I am updating my mods via the Mods menu.
Steps to Reproduce: When opening the game, I accepted the list of mods being loaded and went to the Mods menu to update them / see if I can configure them now.

It got most of the way through the process and hard closed the program- no "this program has stopped responding" or anything just *boot*.

Potentially I might have edited a file within one of the mod folders at some point (though not introducing a bug or anything that would actually cause a crash); I am not certain if this is related, but it's possible.

 

*edit* attached files in that form are still not working lol- reattached log.txt

log.txt

Link to comment
Share on other sites

These errors are showing up in your log:

../mods/workshop-375850593/images/newslots.tex is 340x68 but compressed textures must have power of 2 dimensions.
../mods/workshop-358966231/images/arrow-style1.tex is 100x100 but compressed textures must have power of 2 dimensions.
../mods/workshop-358966231/images/arrow-style2.tex is 100x100 but compressed textures must have power of 2 dimensions.

Those mods are "Compass HUD" and "[DST]Extra Equip Slots"... looks like the images are sized incorrectly, which can cause crashes for sure. Are either of those one of the files you may have edited? Can you try unsubscribing from them in the Steam workshop, deleting the mod folders, then restarting the game again?

Link to comment
Share on other sites

Thanks for the input mate. Those have always been like that for the compass hud (log has always had those lines) and they're as the author published; there's no new or adjusted texture to be had sadly, and it wasn't causing the mods menu to crash for the last month or so I've been running it as far as I can tell (not that I can really tell anything at all in this case lol)

 

The mods menu rarely crashes too; if it were a direct issue with one of those textures it should always crash, or never crash I would expect.. hmm..

 

As far as removing mod folders and unsubbing goes, the next time I open the game after the mods menu has crashed, the mods menu works just fine and goes through the exact same process it tried last time round, so I can't really test anything like that since there's no way to tell the difference between success and what happens by default. I was kinda relying on the log revealing something, but it seems not. Oh and neither of those mods were edited.

Link to comment
Share on other sites

Have you tried uninstalling every mod (by removing it from the mods folder completely), then updating the game, then reinstalling the mods?

 

Edit: or perhaps, before even that, just deleting the mod configuration file which is the source of the first large block of errors in your log and seeing if the game will run.

 

Link to comment
Share on other sites

Sure I've done that previously to debug an inability to generate a new world. Unfortunately as I said, the crash isn't particularly reproducible and does not occur on the next launch of the game.

 

Might just be the current Klei modinfo config bug I spose..

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.