Jump to content

Is there a way to completely disable controller input?


Recommended Posts

Hey. As a poor person, I saved up a while to afford a steam deck when my old laptop broke instead of going for a new laptop, as it is way more powerful than any laptop I could ever afford. I mainly just use it in a dock as a faux pc. I've recently been trying to play DST on it, and it works fine with a controller/handheld but when it comes to playing with a keyboard+mouse, it just doesn't work properly. First off, it defaults to controller, kind of annoying but whatever, I can just change it. The issue is when I try to actually join a world, It defaults BACK to controller input. I've tried everything I could find, typing -nocontroller into the advanced steam options, disabling every button in the steam controller layout thing, searching forums to try and find an answer. I can't start a world and properly play without having to reach over to the steam deck just to press start after picking a character, and I have to reselect k+m input 3 or 4 times every time I launch the game and try to play. The input just simply refuses to stay as the option I picked, and constantly reverts back.

Link to comment
Share on other sites

That's a DST issue.

Other games work just fine with the steam deck in docked mode with kb + m attached.

 

I think you can reproduce this behavior on the pc or laptop by plugging in a controller and dst will always default to use controller over m+kb. That's why i have my Xbox360 Controller unplugged most of the time.

Link to comment
Share on other sites

It's just a DST issue. Even when disabling every button available for the steam deck or making it so all the buttons/sticks/etc. are bound to Kb+M inputs, it still recognizes it as a controller. This is the only game where I have that issue, every other game I've played (that prioritizes controllers when plugged in) recognizes the steam decks built in controller as disabled and uses Kb+M without issue.

Link to comment
Share on other sites

To anyone reading this in the future, I found a way to disable it, and the steam decks built in controller in general (cause I had minor issues in other games, like project zomboid, or games where it defaulted to the steam deck.) I installed this [https://github.com/scawp/Steam-Deck.Auto-Disable-Steam-Controller], then used the command lsusb to add my keyboard and mouse to the list of things that disables the steam decks controller and it works perfectly now. If you want to play handheld again, you'll have to reboot your steam deck after unplugging it from the dock or unplug your Kb+M (or disable them if you're using a usb hub which lets you toggle the individual ports, like I am) before removing the steam deck from the dock/usb-c cable plugged into it. It also isn't exclusive to desktop mode, it works in game mode as well.

Link to comment
Share on other sites

Got this working too. For some reason the script wouldn't recognize either of my input devices though (kb+m). they're both from logitech.

I got this working by adding my usb headset to the list. I was wondering what the driver name of the built in controller maybe would be because you could disable specific drivers in the linux terminal by using the modprobe command and then possibly make one-click quick switch scripts that enable or disable the built in controller for whenever you go portable mode again.

This might be another way for users to fix this issue but imo this should be fixed by valve so they make it so once the Deck is in docked mode that it would disable the built in controller and then use usb or bluetooth devices instead.

And game devs can fix this too. i'm quite puzzled why Klei didn't do this yet. Like idm having the game default to controller when the device is detected but when i switch it off in the settings let it remain off.

Link to comment
Share on other sites

I've only attempted DST with KB+M on my Steam Deck a couple times, but I believe what I had to do was:

1. Exit to Desktop mode (Steam menu -> Power)

2. Run Steam from Desktop (do not go back to Gaming Mode)

3. Go to DST and configure the app -> select Force Compatibility Tool and set the pulldown to Steam Linux Runtime

4. Launch the game.  I can't recall if you are allowed to use Big Picture or not, but I'm pretty sure you can't go back to Gaming Mode.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
  • Create New...