Jump to content

60fps looks like 30fps in 165Hz monitor [ Solved in a really annoying way ]


Recommended Posts

I recent bought a 165Hz laptop and it can run the game 60fps at all time but It feels like 30fps. I used to own a 60hz but even 60hz is smoother. Same thing happened with terraria. My friend with a 144Hz run perfectly smooth tho. Anyone got any ideas?

I tried : 
+ Change Nvidia refresh rate to 120hz, 60hz but it's still weird

Link to comment
Share on other sites

turn off netbook mode since I think that caps the game at 30fps, if not try turning on the steam fps counter and see if everything's working fine, keep in mind the game's animations are capped at a certain speed because they are done frame by frame so there are no extra frames to display, it's part of the art style, your mouse should have uncapped fps though

here are my settings for the mouse to move at the proper 144fps, check the refresh rate settingimage.thumb.png.b654cc554c173d9fef55b0ee16688c06.png

Link to comment
Share on other sites

Just now, Guille6785 said:

turn off notebook mode (or whatever its called) since I think that caps the game at 30fps, if not try turning on the steam fps counter and see if everything's working fine, keep in mind the game's animations are capped at a certain speed because they are done frame by frame so there are no extra frames to display, it's part of the art style, your mouse should have uncapped fps though

here are my settings for the mouse to move at the proper 144fps, check the refresh rate settingimage.thumb.png.b654cc554c173d9fef55b0ee16688c06.png

Mine is on default setting so netbook mode is disabled. Both steam fps counter and ingame counter is at 60fps 

Link to comment
Share on other sites

40 minutes ago, Guille6785 said:

here are my settings for the mouse to move at the proper 144fps, check the refresh rate setting

Two questions. How did you manage to set the refresh rate to anything higher than 60? Everytime I change that setting it resets back to 60. Someone even post a bug report about it but as far as I remember it never got addressed.

Also do you know what disabling the texture streaming does exactly? I'm a little hesitant to turn it off since I have been performance issues with my device lately while playing games, not just DST. But I have no idea what that setting does so there is also that ¯\_(ツ)_/¯

Link to comment
Share on other sites

7 minutes ago, mr. brj said:

Two questions. How did you manage to set the refresh rate to anything higher than 60? Everytime I change that setting it resets back to 60. Someone even post a bug report about it but as far as I remember it never got addressed.

Also do you know what disabling the texture streaming does exactly? I'm a little hesitant to turn it off since I have been performance issues with my device lately while playing games, not just DST. But I have no idea what that setting does so there is also that ¯\_(ツ)_/¯

Mine is 165 :/ no idea how

I think Texture streaming has to do with loading area around you. Being on takes less and off takes more RAM. My old laptop run smoothly with it being off but takes up to 95% ( 8gb ) and randomly makes fps drop with it on as it loads the area 

Link to comment
Share on other sites

21 minutes ago, mr. brj said:

Two questions. How did you manage to set the refresh rate to anything higher than 60? Everytime I change that setting it resets back to 60. Someone even post a bug report about it but as far as I remember it never got addressed.

Also do you know what disabling the texture streaming does exactly? I'm a little hesitant to turn it off since I have been performance issues with my device lately while playing games, not just DST. But I have no idea what that setting does so there is also that ¯\_(ツ)_/¯

turn fullscreen + I think you have to open and close the game a few times idk it also didn't work for me at first

also I think texture streaming makes it so sprites are loaded as needed instead of all at once upon loading a new screen, it lowers ram consumption but causes things to pop in and out of existence, most noticeably in the wardrobe

Link to comment
Share on other sites

If you play DST at FPS higher than 60 it will look choppy and laggy. On monitors which go above 60hz+ it will also inherently not look as smooth as monitor which is native 60hz, unfortunately... The best way to see the smoothness difference you're missing out on is watch a DST video which is at 60fps on your phone (which supports 60fps) and you will see it looks a lot more smooth then you can feel sad...

Also, don't bother with the frame rate settings in DST they are pointless and don't do anything to make the game look smoother if you are running at higher than 60hz.

Anyways, I had this problem before when I swapped to a 144hz monitor and there's only one way to get around it though the game will sitll not look as smooth as playing on a native 60hz monitor (the sad fate of all games locked to 60fps on 60hz+ monitors) here are the steps.

  1. Open your Nvidia Control Panel
  2. Click on "Manage 3D Settings"
  3. Click on "Program Settings"
  4. Tick the check box "Show only programs found on this computer"
  5. Wait several minutes until it loads the programs
  6. Select the program "Don't Starve Together (don't starve together/bin/dontstarve_steam.exe)"
  7. Then scroll down in the "2. Specify the settings for this program:" and find "Max Frame Rate" and set it to "On" and put the FPS limit to 60
  8. Then scroll lower and turn off "Vertical Sync"
  9. Click Apply button and then wait for your cursor to stop buffering and then close the Nvidia Control Panel
  10. Open Don't Starve Together and make sure full screen is enabled and your max frame rate is at 60
  11. Enjoy your smooth but not as smooth as a native 60hz monitor DST experience
Link to comment
Share on other sites

6 hours ago, . . . said:

If you play DST at FPS higher than 60 it will look choppy and laggy. On monitors which go above 60hz+ it will also inherently not look as smooth as monitor which is native 60hz, unfortunately... The best way to see the smoothness difference you're missing out on is watch a DST video which is at 60fps on your phone (which supports 60fps) and you will see it looks a lot more smooth then you can feel sad...

Also, don't bother with the frame rate settings in DST they are pointless and don't do anything to make the game look smoother if you are running at higher than 60hz.

Anyways, I had this problem before when I swapped to a 144hz monitor and there's only one way to get around it though the game will sitll not look as smooth as playing on a native 60hz monitor (the sad fate of all games locked to 60fps on 60hz+ monitors) here are the steps.

  1. Open your Nvidia Control Panel
  2. Click on "Manage 3D Settings"
  3. Click on "Program Settings"
  4. Tick the check box "Show only programs found on this computer"
  5. Wait several minutes until it loads the programs
  6. Select the program "Don't Starve Together (don't starve together/bin/dontstarve_steam.exe)"
  7. Then scroll down in the "2. Specify the settings for this program:" and find "Max Frame Rate" and set it to "On" and put the FPS limit to 60
  8. Then scroll lower and turn off "Vertical Sync"
  9. Click Apply button and then wait for your cursor to stop buffering and then close the Nvidia Control Panel
  10. Open Don't Starve Together and make sure full screen is enabled and your max frame rate is at 60
  11. Enjoy your smooth but not as smooth as a native 60hz monitor DST experience

I did all above but still not smooth lol. I guess I found the only solution : uninstall the game. Thanks all for helping me. A gaming laptop but cant run any 60fps cappes games properly lmao

Link to comment
Share on other sites

- After I gave it another shot, I installed the game again and got it to work buttery smooth now. Here's how I did it:
+ [ IDK how this failed ] So on my legion 5 it has a mux switch to switch between hybrid mode and dgpu only mode. Put it on hybrid mode and choose nvidia gpu only in nvidia control panel, but cannot change monitor refresh rate windows setting so I change it to 60Hz in nvidia control panel instead, and after that it is 60Hz now that I know the mouse movement and everything. Got into the game and nope the game is like ghosting and juddering
+ [ Success ] I put it to dgpu mode. This enabled gsync ( idk if it works with dst because there wasnt any gsync indicator shows up in dst but it does in Terraria ). Installed CRU to add a 60Hz profile ( because legion 5 is locked at 165Hz )  switch it to 60Hz, got into the game (somehow dst opening switch display back to 165Hz and make me switch to 60Hz again so Ill just switch it after the game opened )  and yeah its as smooth as my old laptop now. I do have to switch back to 165Hz after exiting tho
- Downside Manually change refresh rate and mouse moves at 60Hz which is really weird if you already got used to anything higher then 60Hz, Also because I have to use dgpu mode, igpu is physically switched off making dgpu handle everything => high fan speed and thermal stuff probably ( dont notice yet ). If I want to use both gpu again then Id have to go back to hybrid mode (requires a restart) really annoying
- I post it on facebook game forum and legion game forum aswell and Bruh, some people actually have the same problem
- I still dont know how my friend with a 144Hz monitor can run the game smoothly without any problem leaving it everything default
----------If this doesnt help anyone with the same problem then the keyword I found is "judder". Help yourself I guess-----------------------

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
  • Create New...