Jump to content

What mod could cause this?


Recommended Posts

I'm sometimes getting an error and it's been happening in situations so diverse that:

  • I cannot disable mod by mod and check whether it still happens, because it happens randomly and at long intervals
  • I cannot pin-point the exact mod by observing when it happens, since the game crashes in wildly different situations
NullReferenceException: Object reference not set to an instance of an object

RancherChore+RancherWorkable.OnPendingCompleteWork (Worker work) (at <7e5a6eddfdfc4c1da900a524ff2b6754>:0)
Worker.Work (System.Single dt) (at <7e5a6eddfdfc4c1da900a524ff2b6754>:0)
GameStateMachine`4+State+<>c__DisplayClass80_0[StateMachineType,StateMachineInstanceType,MasterType,DefType].<ToggleWork>b__1 (StateMachineInstanceType smi, System.Single dt) (at <7e5a6eddfdfc4c1da900a524ff2b6754>:0)
BucketUpdater`1[DataType].Update (DataType data, System.Single dt) (at <8c239b169b544cce8b8bc7ddd2d09e10>:0)
UpdateBucketWithUpdater`1[DataType].Update (System.Single dt) (at <8c239b169b544cce8b8bc7ddd2d09e10>:0)
StateMachineUpdater+BucketGroup.AdvanceOneSubTick (System.Single dt) (at <8c239b169b544cce8b8bc7ddd2d09e10>:0)
StateMachineUpdater.AdvanceOneSimSubTick () (at <8c239b169b544cce8b8bc7ddd2d09e10>:0)
Game.SimEveryTick (System.Single dt) (at <7e5a6eddfdfc4c1da900a524ff2b6754>:0)
Game.Update () (at <7e5a6eddfdfc4c1da900a524ff2b6754>:0)

Build: U42-512719-SD

My mod list:

blueprints fixed
threshold walls
paint wallls
better air filters updated
useful tags lite
pliers 2021
waste not want not
traffic visualiser
efficient supply
better info cards
build over plants
engineer build priority
suppress notifications
enable achievements
wallpaper
more marble sculptures
decor reimagined
no long commutes
queues for sinks
no drop
repeat last build
tinted aquatuner liquid
worn suit doesn't drop canister
true tiles
replace floors
sealed pump
mod manager

 

Link to comment
Share on other sites

9 minutes ago, Sanchozz said:

look, here is the same error as yours. marked that it will be fixed in a future version.

 

I was so sure this could be mod-related I didn't even look for vanilla bug errors. Thank you!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...