Jump to content

Mods Problem on Dedicated Servers


Recommended Posts

Since the update that mods now are downloading instantly, I had some problems,

Like some mods, are not showing on steamapps\common\Don't Starve Together\mods directory, like (reforged, epic health bar)

They only appear on this folder steamapps\workshop\content\322330, so I have to copy and paste then on mods folder, and start the server like this

But if I do anything on the game, it delete the mod I just paste ifself, if they use the default folder "workshop-xxxxxxxxx".

So I am renaming then to not get deleted.

- How do I use the new system of mods ? I use the modoverrides.lua but like this Im not sure if it's right.

- Is it possible to point the modoverrides to another directory ?

Link to comment
Share on other sites

On 6/20/2021 at 10:40 PM, Kaio17 said:

How do I use the new system of mods ?

Details:

TL;DR:

  1. Check server log and ensure that SteamGameServer_Init succeeds.
  2. New/updated mods do require their own directory.
    Copying them under the old directory may work around the issue in the point above, but this will come back to bite you when the mods are updated. I strongly recommend deleting the updated mods from the legacy directory and using strictly the new mod directory for those.
  3. Use the --ugc_directory to point the server to whatever directory you like.
On 6/20/2021 at 10:40 PM, Kaio17 said:

I use the modoverrides.lua but like this Im not sure if it's right.

Yes, I was confused too at first - you keep using the "workshop-<mod-id>" keys in the modoverrides, even for new/updated mods. No need to change anything here.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...