7Meias

Custom tab disappears on cave worlds ? [SOLVED]

Recommended Posts

7Meias    247

EDIT: The problem reappeared and im not sure why! It's the same thing as on the previous time: tab appears on normal worlds but doesnt in ones with caves enabled. I've already tried to change the priority to 2, 8, 996, 998, 999 and even moving the command within the code a couple times but none worked. Does anyone have ideas?

local springtab = AddRecipeTab("Floriography", 998, "images/mytab/maxtab.xml", "maxtab.tex", "canebuilder")

my new mod main:


modmain.lua


-- -- -- -- -- -- -- -- -- -- -- 


Pretty much what the title says, I really don't know why, but my UI looks different from when I have caves enabled or not. I've never had a problem like this before, and I've tried many things already to no avail. Basically, my custom character is supposed to have his custom tab (Floriography) popping up whenever he holds an item (houndcane), and it was working so far on the worlds I was testing

image.thumb.png.e8b6d5137e4d935a18c5f6204015b6b7.png

not holding item > holding item
(dont mind the tab doesnt have an image yet, I'll take care of the graphics once the mod is done)

But once I enable caves, the UI ""shrinks"" and I'm unable to see my tab, then, and also unable to use it

 

image.png.771271f8e075f5348431f0d819df19ed.png

third one is how my UI looks on cave worlds for comparison

Any ideas? Here's my modmain btw, where my custom tab is, and the code of adding a tab i used

modmain.lua

local maxtab = AddRecipeTab("Floriography", 999, "images/mytab/maxtab.xml", "maxtab.tex", "canebuilder")

 

EDIT (scratch this, problem returned)

Pfft, I think my head was a bit too tired to think of new ideas xD Cause after a little nap I figured it out.

Changed the priority of my tab, when sorting it out, and that seemed to do the trick. I kinda liked it being in the  bottom more, but at least this works :grin:

local maxtab = AddRecipeTab("Floriography", 2, "images/mytab/maxtab.xml", "maxtab.tex", "canebuilder")

image.png.147972d3622e27f1d4f1b0a514bf87e9.png

modmain.lua

Edited by 7Meias

Share this post


Link to post
Share on other sites
TheSkylarr    18

Hey, I know you solved this, but I had this happen to me as well when I first added my own crafting tab, I found that 999 caused problems sometimes, so I personally used 998, you could trying another weird high number like 997 or something, and see if it works properly like you want it.

Share this post


Link to post
Share on other sites
7Meias    247
19 hours ago, TheSkylarr said:

Hey, I know you solved this, but I had this happen to me as well when I first added my own crafting tab, I found that 999 caused problems sometimes, so I personally used 998, you could trying another weird high number like 997 or something, and see if it works properly like you want it.

Oh thank you very much!! I'll test some of these random higher numbers then!!

Share this post


Link to post
Share on other sites
Ultroman    725

I think it might be as simple as: nothing "vanilla" with special crafting tabs is available in the Caves, so why not make the game shrink the tab-list while you're in Caves? Can you still access the tab using a controller or scrolling down on the list when it happens?

Edited by Ultroman

Share this post


Link to post
Share on other sites
penguin0616    896
28 minutes ago, Ultroman said:

Can you still access the tab using a controller or scrolling down on the list when it happens?

Definitely try that. Crafting tabs are good at being sneaky.

 

If you still cannot find your tab, make sure that you are actually adding the tab on both the client and the server.

Edited by penguin0616
  • Like 2

Share this post


Link to post
Share on other sites
7Meias    247
On 3/1/2021 at 4:58 PM, Ultroman said:

I think it might be as simple as: nothing "vanilla" with special crafting tabs is available in the Caves, so why not make the game shrink the tab-list while you're in Caves? Can you still access the tab using a controller or scrolling down on the list when it happens?

Sorry I took so long to answer you guys, life has been quite busy haha No, when caves were enabled, I couldnt access the tab on controller nor through scrolling down! But what penguin said down there helped me a lot~

On 3/1/2021 at 5:26 PM, penguin0616 said:

Definitely try that. Crafting tabs are good at being sneaky.

 

If you still cannot find your tab, make sure that you are actually adding the tab on both the client and the server.

Yeah, I initially had my tag only on master_postint, so i moved to common_postint and it seemed to work!! Tysm 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now