Jump to content

Game crash after update (Mac os Catalina)

Recommended Posts

Hi ! I have recently been accepted to the Alpha and the game was working fine before the latest update. I tried reinstalling the game and deleting or the save files, still getting the error. Looking at my mac os console output I am getting this error when running the game :

Nov 29 08:17:13 host com.apple.xpc.launchd[1] (unity.Klei.Oxygen Not Included.31792[63174]): Could not find and/or execute program specified by service: 2: No such file or directory: /Users/myself/Library/Application Support/Steam/steamapps/common/OxygenNotIncluded/OxygenNotIncluded.app/Contents/MacOS/OxygenNotIncluded

Seems like some sort of file has gone missing and can't locate it. I may be able to fix that manually somehow, but at the moment the game is not loading at all on Mac os since the latest update a few days back.

EDIT: Just checked that path, only contains the file "Oxygen Not Included Restarter", which upon execution attempts to start the game but also fails with the same error message.


Link to comment
Share on other sites

uninstalling and reinstalling the game has fixed this most of the time. For me, i did that, cleared cache, and a few other things, when i booted up ONI it crashed immediately, but then when i tried again it opened fine.

This has also been reported in the bug forum in multiple instances, so you might want to go searching there for any exotic answers if uninstall/reinstall doesn't do it for you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...