Recommended Posts

The server (caves) says this:

 

[00:00:15]: [Shard] Connection to master failed. Waiting to reconnect...
[00:00:20]: About to start a shard with these settings:
[00:00:28]:   ShardName:
[00:00:28]:   ShardID: 2456401617
[00:00:28]:   ShardRole: SLAVE
[00:00:28]:   MasterHost: 127.0.0.1
[00:00:28]:   MasterBind: (null)
[00:00:28]:   MasterPort: 11002
[00:00:28]: [Shard] Connecting to master...
[00:00:30]: [Shard] Connection to master failed. Waiting to reconnect...

and so on.

 

 

 

I'm new to the forums btw

Share this post


Link to post
Share on other sites
Electroely    1,762

Could you upload your caves and master's server.ini and the server's cluster.ini?

Share this post


Link to post
Share on other sites
Daniel86268    22

Your Master_Port doesn't match up with the Master shard port. They need to be identical. Atm your slave shard tries to connect to a master shard on the port 12348 or 11001 (Since you defined different master ports in the cluster.ini and server.ini, not sure which ont it takes.) while the Master shard is listening on the port 10999. Set all Master shard ports on 10999 for example and it'll most probably work.
Also make sure to start up the master shard first, sonetimes the slave shard has issues to connect to the master shard if the slave started up first.

Also... you should only have one cluster.ini which sits right next to the Master and Cave directories Not sure where you stored them, but it should look like this:
DSTserver.png.1cce603ff5d9e5bc58a0b7f8ac8366ac.png

Don't mind my image editing skills, but I think it should represent pretty well how it should look like.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now