[String] Unable to translate Game Setting Option


Ozcuraz
  • Branch: Live Branch Version: Windows Closed

5ddea8646616a_gamesetting.thumb.jpg.0f9b76b5d92fff172f9f81ab3eb7f77b.jpg

all of the above menu/option was once translatable before Meep's Recreation Pack. Now they are not translatable anymore.

 


Steps to Reproduce
Change translation, create new game and click on customized game setting in world selection screen.

Status: Closed

This issue has been closed either because it is not a bug or does not belong in the bug tracker.


  Report Bug


User Feedback


....

Hi, I believe we are still using the proper string keys for these settings - they all have the prefix

"STRINGS.UI.FRONTEND.CUSTOMGAMESETTINGSSCREEN.SETTINGS.*"

For example: "STRINGS.UI.FRONTEND.CUSTOMGAMESETTINGSSCREEN.SETTINGS.CAREPACKAGES.NAME"  - > "Care Packages"

Attached is a screenshot of the live build using these strings with our built-in Chinese language option.OxygenNotIncluded_OkjOq88jvQ.png

Share this comment


Link to comment
Share on other sites
....

I created a testing file to verify that it is un-translatable here: strings.po

The file only contains the following strings (no localized font required):

1.

#. STRINGS.UI.FRONTEND.NEWGAMESETTINGS.HEADER
msgctxt "STRINGS.UI.FRONTEND.NEWGAMESETTINGS.HEADER"
msgid "GAME SETTINGS"
msgstr "GAME SETTINGS (TESTING BUG)"

2.

#. STRINGS.UI.FRONTEND.CUSTOMGAMESETTINGSSCREEN.SETTINGS.CALORIE_BURN.LEVELS.DEFAULT.NAME
msgctxt "STRINGS.UI.FRONTEND.CUSTOMGAMESETTINGSSCREEN.SETTINGS.CALORIE_BURN.LEVELS.DEFAULT.NAME"
msgid "Default"
msgstr "Testing"

Here is SS taken while using the testing po file.

5ddf331acab98_difficultyoptionhunger.thumb.jpg.ec611a396464b66cb5175fbb2cc1f313.jpg

The word "GAME SETTINGS" is translated according to the testing file while the word "Default" is not translated.

Could you test by replaced strings.po into the StreamingAssets/Strings instead of using a pre-installed language file? It seems that the behavior between pre-installed language pack and those from Steam Workshop are different.

Share this comment


Link to comment
Share on other sites
....

I used other translator' po file for testing. With the same file, my result and his were different. It seemed that there was something wrong on my end. After reinstalled ONI, my problem has been resolved.

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now