fatheroctopus

Developer
  • Content Count

    322
  • Joined

Community Reputation

499 Excellent

About fatheroctopus

  • Rank
    Senior Member
...

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Enable
  1. Changed Status to Fixed
  2. Hi @randomdude, this is a bug in the Steam Linux client - it can be fixed by right-clicking on Griftlands in the Steam library -> Properties -> Compatibility tab. Toggle the "Force the use of a specific Steam Play compatibility tool" checkbox on and off again. That should clear the bug and prompt the client to download the correct executable. Thanks for the report!
  3. Just a heads-up that the --nomipmaps workaround mentioned above is now in the live build. Let us know if this doesn't address the crash - Thanks!
  4. Hi, we have an update on this - the issue is caused by an interaction between a specific driver for some Macbook GPUs and our mipmap textures. We will add an optional launch parameter that allows users to disable mipmaps. This workaround will go live next week, but if you want to try it out before then, you can switch to our "experimental" beta branch on steam. Once on the experimental branch, to enable the workaround: 1) Find "Launch Options" by context-clicking on Griftlands in the steam library -> Properties -> General 2) Add --nomipmaps to the "Launch Options" field. This will degrade texture quality in some instances, but should avoid this crash. Let us know how that works out for you, or feel free to wait until next week to try it out.
  5. Ok, I'm not surprised that it still crashes, as lowering resolution probably changes some timings and memory usage, but doesn't address the core problem. Since we can now repro this reliably, no more information is needed - thanks for your help, I'll update this thread when we learn more.
  6. Great! - and also very interesting. We have managed to reproduce this error on a machine on our end, so we'll keep plugging away at getting it working at native resolution.
  7. @Yozabroza There are a few tests that could provide some useful info: Assuming that continuing from a given save always crashes for you, does it crash... 1) ...when the steam overlay is disabled? (Right Click on Griftlands in library -> General -> Uncheck "Enabled the Steam Overlay while in-game") 2) ...in both full-screen and windowed mode? (Accessed via "Graphics" tab in the in-game settings) 3) ..at a different resolution from your default settings? Thanks!
  8. Hi @Yozabroza, just a quick update - the bug appears to be hardware dependent and I've had trouble reproducing on my own devices. This is substantiated by the bug report you attached, which shows the error occurring in a graphics driver library. We're currently relying on some static analysis tools to try to identify the bug - when a candidate fix is released I'll be sure to update this thread to see if it fixed things on your end. Thanks for your patience!
  9. Hi @Yozabroza and @baevar - does this occur every time for you, regardless of what save you're loading? If it's not every time, could you attach a copy of a .sav file that exhibits the crash? Instructions for finding your .sav are in the link below - thanks for the report! https://support.klei.com/hc/en-us/articles/360044520732-Logs-and-Useful-Information-for-Bug-Reports-for-Griftlands-Early-Access-
  10. It appears that the Steam client was hotfixed late yesterday with a fix for launching games on Mac. They don't call out Mojave though, so let us know if you're still unable to launch after updating steam.
  11. Hi, the latest build has some changes that might address this crash, let us know if you still encounter it after updating. Thanks!