Oxygen Not Included inexplicably crashes upon opening every single time


PissedCustomer
  • Branch: Live Branch Version: Windows Pending

Every time I attempt to open the game, it shows the Klei logo, and instantly cuts to the "your game crashed" screen. (The bug reporter there doesn't work either, but that's irrelevant.) So far I have attempted to verify the game cache, restart the game, restart Steam, start Steam in offline mode, restart my computer, uninstall and reinstall the game, and check my anti-virus for possibly blocking the game. None of these have succeeded in getting past or removing the bug.

DxDiag.txt


Steps to Reproduce
Click the game on Steam. Select "Play."

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

Sorry to hear that you are having trouble with the game. If Oxygen Not Included is getting stuck on the Klei Logo or crashing at the Klei logo when you are trying to launch the game, please follow these troubleshooting steps to resolve it:

a) Try resetting the game to it's default setting values by deleting a file called "kplayerprefs" in the OxygenNotIncluded folder in your documents. So if you go into your documents folder at C:\Users\{Your Windows User account}\Documents\Klei\OxygenNotIncluded\ and delete the "kplayerprefs.yaml" file

b) If you have MODS installed, please delete the mod files, then unsubscribe all of your mods from the Steam Workshop to see if one or a couple of the mods are causing the issue. From there, enable them one at a time.

c) If the issue still persists, go into your Oxygen Not Included folders in Steam and delete modloader.dll as well as the mods folder located in your documents folder. Here's how to do that:

MODLOADER.DLL

- Open up Windows Explorer, and go to your Oxygen Not Included folders in Steam. steam\steamapps\common\OxygenNotIncluded\OxygenNotIncluded_Data\Managed\
- Look for the file called modloader.dll and delete it.
- Close Windows Explorer and launch the game.

MODS FOLDER

- Open up Windows Explorer, and go to your documents folder at C:\Users\{Your Username}\Documents\Klei\OxygenNotIncluded\
- Delete the contents in your "mods" folder.
- From there, launch Oxygen Not Included once more and try running the game.
 

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

Hey! Have a super similar problem, still working on it to be honest, but one thing I didn't think to check and was probably a factor, check in your game properties that the file isn't set to read only! Unsure if this'll be the solution for you but never hurts to check!

Share this comment


Link to comment
Share on other sites
....

just checked if you have windows ransom protection on or have your documents game save set as read only it will crash the game right away 

Share this comment


Link to comment
Share on other sites
....
20 hours ago, JanH said:

Sorry to hear that you are having trouble with the game. If Oxygen Not Included is getting stuck on the Klei Logo or crashing at the Klei logo when you are trying to launch the game, please follow these troubleshooting steps to resolve it:

a) Try resetting the game to it's default setting values by deleting a file called "kplayerprefs" in the OxygenNotIncluded folder in your documents. So if you go into your documents folder at C:\Users\{Your Windows User account}\Documents\Klei\OxygenNotIncluded\ and delete the "kplayerprefs.yaml" file

b) If you have MODS installed, please delete the mod files, then unsubscribe all of your mods from the Steam Workshop to see if one or a couple of the mods are causing the issue. From there, enable them one at a time.

c) If the issue still persists, go into your Oxygen Not Included folders in Steam and delete modloader.dll as well as the mods folder located in your documents folder. Here's how to do that:

MODLOADER.DLL

- Open up Windows Explorer, and go to your Oxygen Not Included folders in Steam. steam\steamapps\common\OxygenNotIncluded\OxygenNotIncluded_Data\Managed\
- Look for the file called modloader.dll and delete it.
- Close Windows Explorer and launch the game.

MODS FOLDER

- Open up Windows Explorer, and go to your documents folder at C:\Users\{Your Username}\Documents\Klei\OxygenNotIncluded\
- Delete the contents in your "mods" folder.
- From there, launch Oxygen Not Included once more and try running the game.
 

Followed all the steps. Game still crashes on launch. Though, I didn't actually have the file "modloader.dll" if that's relevant.

 

15 hours ago, Momfriend616 said:

Hey! Have a super similar problem, still working on it to be honest, but one thing I didn't think to check and was probably a factor, check in your game properties that the file isn't set to read only! Unsure if this'll be the solution for you but never hurts to check!

It was, but that didn't fix anything. Thx for the advice anyways.

2 hours ago, kingy10005 said:

just checked if you have windows ransom protection on or have your documents game save set as read only it will crash the game right away 

The ransom protection is ignoring the game per my orders. Still crashing. If I just delete the entire folder and empty the trashbin, do you think that might work?

Edited by PissedCustomer
needed to clarify something

Share this comment


Link to comment
Share on other sites
....

I'm afraid this happens as well in the Linux build. Upon trying to launch the game in Steam client it'll say it's running and shortly afterwards, without showing anything: not even a Klei logo, nada; close and show that it's not running.

Share this comment


Link to comment
Share on other sites
....

For me (also Linux), it makes it to the Klei logo, then locks up.  If I move my .config/unity3d/Klei directory, it locks up at an all white screen.  Broken on the dev build too.

Share this comment


Link to comment
Share on other sites
....

did you try turning off ransom protection ?

also did you try reinstalling the game with no mods etc ? 

 

also if non of that worked try maybe making a new user account if that works could be file permissions being set wrong 

could also be some thing you have installed and running thats messing with it duno

o by the way do you have the crash log file i mite be able to work out some thing from it :)

Edited by kingy10005

Share this comment


Link to comment
Share on other sites
.... ....

Yeah, when I have some more time to put into it, I'll check it out again.  I'm preparing for a trip and probably shouldn't be dumping another 12 hours into ONI right now anyway :p.  For the record though:

* No mods installed ever

* Game has always run fine in the past -- only stopped working this week.

I'll try out your tips next week when I'm able.

Share this comment


Link to comment
Share on other sites
.... .... ....

@PissedCustomer Sorry for the wait, looking at your log, it looks like either your Steam client or the game application does not have the administrative permissions it needs to be able to read/write your hard drive. Specifically this line in the log: 

[21:59:12.031] [1] [INFO] An Unauthorized Access Error occurred when trying to write to disk.
Please check that you have permissions to write to: (filepath to where your save files are located)

Please try the following steps to see if these help resolve the issue for you:

1) Fully restart your computer, and then log back into your Steam account and try verifying the game cache once more: https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

2) Please ensure that your Windows User Account has the proper administrative permissions.

Windows 7 – https://support.microsoft.com/en-us/help/14028/windows-7-how-log-on-as-an-administrator

Windows 10 – https://www.cnet.com/how-to/how-to-check-if-your-windows-10-account-is-administrator/

3) Run Steam as an Administrator
- Fully close out of Steam and restart your computer.
- After restarting your computer, right-click on the Steam icon > select "Run as Administrator"
- Try launching the game after your Steam Client has full administrator access.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now