Jump to content

Issue with building on new regolith planet

  • Branch: Preview Branch Version: Windows Fixed

Sometimes when duplicants attempt to build something (usually where regolith has fallen), the are stuck trying to dig an invisible block before they can build. I believe this was a previous bug on the base game. I've noticed that there is A LOT of lag when coming to this planet. -~10-15 frames. There is also no space scanner to check for incoming regolith.


Steps to Reproduce

Isn't consistent. Seems like random blocks do this. 

User Feedback

A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Agreed.  Sent in robots to try and dig past the regolith and had the same issue.  You can manually cancel the dig once the falling regolith is dug, but it is a PITA.  It looks like the issue may be trying to accommodate the falling regolith and quick dig speed but gets hung up.

I also have had several glitches with the robots getting bounced and then stuck in an animation that they just freeze or bounce up and down until their battery runs out.  It seems to be more related to incoming meteors that bounce them and then they cannot recover what they were doing.

Share this comment

Link to comment
Share on other sites

Same here. I tried to build bunker doors and there are two places where no matter what dupes do they cannot build. They bring steel and start construction but 0 progress for days. I cancel and do again and the same result. I reload a game and again they do not build in these two specific places - no matter if meteorites are falling or not. The game speed is at 1. The builder has digging skills to max (r/a digging) and he built other bunker doors.

And had one case with a ladder just below the place where I could not build the bunker door. Same problem. FPS is ok, no problem with that.

here is one place - the bunker above could not be built, I cancel and the steel dropped down. It cannot build ladders (actually two of them).


here is another place; they could built ladders but no bunker doors.


I have never had the same problem in the vanilla game.

and thanks for the asteroid; it is very nice to have it. It was the most challenging for me (only radbolt rocket could fly to it, could not find a place (three flat tiles) to land a trailblazer at the first run, all payloads were hard to collect due to uneven surface, etc.) and so far I like it. Two sources of hot steam guarantee that it can be made to the proper outpost.

By the way the rocket platform stops accepting rockets (unlike in a vanilla game) when regolith falls on it. In the vanilla, a rocket lands no matter what even breaking bunker doors. probably it is intentional but it could be a case it may completely prevent colonizing the planet. If all banker doors are built and you open two to land a rocket, regolith parts fall and block the platform for landing. Obviously later it can be a dupe to "free" the platform, automation, robominers, etc.

Share this comment

Link to comment
Share on other sites

some more info:

it looks like not one tile but a vertical line. Nothing can be built on the line as it requires digging so there is nothing to dig.

As you can see the bunker door in the middle, the air permeable tile below, the solid tile and the wire or wire jumper at the bottom - nothing could be built.


Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...