If playing game with one dupe, dupe entering rocket riggers "Colony lost" notification


SomeRandomFinn
  • Branch: Preview Branch Version: Windows Pending

Playing a one-dupe world I was (finally) ready to launch my first rocket.

When the dupe entered the rocket it triggered the "Colony Lost" pop-up notification. Even though the dupe is alive, but is in the rocket.

The red "colony lost" notification in the upper left side of the screen remains, even after the dupe has returned from their space mission.

PIC 1: dupe enters rocket, colony lost pop-up

PIC 2: dupe has returned, colony lost notification still there

 

Suggestion/possible fix: this pop-up could have a check first, to see if there are any dupes in rockets or on space missions (from which they will return, i.e. not the temporal tear)

 

Edit/addition: the resource list also becomes wonky when there are no dupes on the asteroid, when all are in space. Presumably due to how the game calculates what resources can be reached, which goes a bit funny when no dupes are around to reach any resources. The resources don't show 0 for all things - some show there being a bit of resources, many show there being no resources of that type.

LastDupeInRocket.png

 

 

Ruby_ColonyLost.png


Steps to Reproduce

Kill off all dupes but one.

Have them enter a rocket.

Send them on a mission and back.

(Might work with more dupes but just having them all enter rockets.)



User Feedback


....

Ah, so somebody actually tried this. When I tried a 1 dupe colony way back, several people predicted this behavior. I never got even close to launching a rocket though. 

Related issue: When you have a 12 dupe colony, the win-condition of having 12 dupes is also invalidated if one is in a rocket.

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now