Game not going to main menu


A7moGames
  • Branch: Live Branch Version: Windows Closed

Oxygen included always worked for me, with no crashes at all or nothing wrong with the files and suddenly after I abandoned the game for about 2 months I came back to play it again and it shows these messages when the game lunches after I press the "okay" button it just freezes in the "Klei" logo screen.

I have tried to reinstall it, and I have tried to clear space as it says.... and I still can't understand what does it mean with clear space.
I deleted all my saves, and reinstall and nothing worked.
I tried the old method of literally deleting everything about the game, I deleted the game folder itself and reinstalled the game as if like it's my first time playing and it still didn't work, the same messages appear.

PROBLEM WAS: ANTI-VIRUS BLOCKED GAME (OXYGEN NOT INCLUDED)

PROBLEM FIXED.



 

Oxygen not included bug 2.png

Oxygen not included bug 1.png


Steps to Reproduce
I don't know exactly, I did nothing I couldn't find this issue with any of my friends nor with anyone online. I didn't do anything special I was keeping a close eye on my pc, all what I did was just launch the game.

Status: Closed

This issue has been closed either because it is not a bug or does not belong in the bug tracker.


  Report Bug


User Feedback


....

You see the playerprefs.yaml in your first bug-display? Delete it by hand. It wont get deleted when you un/reinstall. It happens the file gets corrupted, and then the game wont start. Dont be affraid, there´s only the settings stored. You can delete it, and when the game runs again, just change everything in the options menu (if you had changed anything that is)

Share this comment


Link to comment
Share on other sites
....

As I mentioned in my report, I did delete everything in the game folder including all the saves and files even the playerprefs.yami and I still have the same problem, it even tells me to go to playerprefs.yami while this file does not even exist in my pc.

Share this comment


Link to comment
Share on other sites
....

One thing i noticed... it says /Users/user/.... is this your working user folder? Or may it be something like /Users/A7moGames/...?

Another thing is some anti-virus software suits cause problems. Have to taken a look at this issue?

Just trying to help here...

Edited by SharraShimada

Share this comment


Link to comment
Share on other sites
....

User/user and what's after that is the location of the oxygen not included folder.
About the anti-virus, anything that my anti virus stops or blocks, I should immediately know about but I got no such a report from my anti-virus.

How much time will it take for a developer to see this and try to fix my problem... because I literally can't play the game at all, it's as if I bought a game that does not start.
As I said I tried everything, I even started from "zero" and with zero I mean, I deleted everything about the game and reinstalled it after that, and still the same problem and same messages.

Share this comment


Link to comment
Share on other sites
....

If you could post your DXDIAG and output log that's help narrow things down greatly.

Going off of what you've told me, in the first picture, the game doesn't have permission to edit files, so either run it as admin or go into your AV software and add it to your whitelist. And judging from the second picture, do you have enough space left on your hard drive to have the game run? This is where the DXDIAG would help things.

 

 

Share this comment


Link to comment
Share on other sites
.... ....

Thats only the DXDIAG, what about the games output.log file?

And regarding the folder, it may contain the ONI-Files, but is this YOUR working home folder? Is this where your documents and other files get stored? If not, the game has chosen a wrong folder to store the data (for any reason) and therefore there are permission issues.

Edited by SharraShimada

Share this comment


Link to comment
Share on other sites
....

Here is the output.

output_log.txt

The game is storing data at the right place, as I said before it was the wrong place the problem would have occurred long tie ago, the game was working fine with me for almost 1 year, I bought the game around 1 year ago.
The file where the games stores everything is the Klei file, which has Don't Starve Together and Oxygen not Included file, and it stores any other steam games published by Klei.

So that means the game files and saves are stored in the right place.
Right now the game folder has no "playerpref.yami" folder, I deleted everything to try to fix the issue but when I reinstalled the game it created the Mod file and the save files only, it didn't creat playerpref.yami, I don't know if I should add it myself.

Share this comment


Link to comment
Share on other sites
....

from your log:

[11:00:21.416] [1] [INFO] ASSERT: Test Data Locations / failed to write C:\Users\user\Documents\Klei\OxygenNotIncluded\test: Access to the path "C:\Users\user\Documents\Klei\OxygenNotIncluded\test" is denied.

 Access to the path "C:\Users\user\Documents\Klei\OxygenNotIncluded\mods\mods.json" is denied. 

 Access to the path "C:\Users\user\Documents\Klei\OxygenNotIncluded\kplayerprefs.yaml" is denied. 
 

This is cleary a permission issue.

You may try to start ONI in admin-mode, this could solve the isse the game cant write to the folder.

Further you can check for folders permissions. There seems to be the issue, not to be allowed to write by whatever reason.

Share this comment


Link to comment
Share on other sites
....

I am sorry, but could you explain it to me from point zero,
I really don't know whats an "ONI admin mode" and I don't know how to even check if oxygen not included has permission to write into disk or no, I would be really grateful if you explained it step by step, thanks.

Share this comment


Link to comment
Share on other sites
....

Okay, for beginners:

I assume you start STEAM either with an icon on your desktop, quicklaunch bar or via start menu. If so, dont left click it, but click right. A menu should open, and there should be something like "Run as Admin" or "Rund as administrator" to select. This will start STEAM in admin mode. Everything you start inside of STEAM should also start in admin mode.

If this wont work, the next solution would be: You open STEAM, select the game, right click on it, and choose "Properties". 

Next: Set Launch Options. Another windows pops up, with an input box. Enter "runas.exe/user:administrator" to the empty field, click okay, and try starting the game again. (i dont really know about the "" right now, so try with and without if its not working)

Thats the easy part. If it helps, Try starting STEAM normal the next time, and see if it runs. If you changed the game starting properties, delete the command, and try again to see if it runs normally too. (the reason is, its never the best solution to run stuff in admin mode all the time)

If the problem is solved, congratulations.

 

 

If not... please ring a bell, and i may provide you with the hard stuff. But i dont want to post this here in the open, because people casually read such stuff, and break the system with it, because they dont know what they´re doing. You may contact me via private message here if you want to. 

Share this comment


Link to comment
Share on other sites
....

I tried everything you mentioned in detail, unfortunately, none of these methods worked out.

-------------------

Uh..... so... I am like.. super sorry to you guys, and I am very super grateful and thankful for your great help.
So I fixed the problem.
It turned out that my Bitdefender anti-virus was blocking the game from writing and reading and opening the game files,
I am really embarrassed about how I never realized that the game application was in the "blocked application" of the anti virus.

Sorry again and thanks a lot for your wonderful help.

Sorry again but last question, how to delete this bug report? Or how to list it as a "Fixed" Bug?

Edited by A7moGames
  • Like 1

Share this comment


Link to comment
Share on other sites
....

Dont be embarrassed please! Believe me, it happens to the "best" of us sometimes. 

I´m just glad you found the culprint and you are able to play again. Have fun.

Regarding the bug-report, a forum-mod will close it soon i believe.

  • Like 2

Share this comment


Link to comment
Share on other sites
.... ....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now