Game crashes after -268.15°C chunks of solid oxygen appear


Zelitor
  • Pending

-268.15°C cold gas no longer seems to crash while in pipes, however after it exits a vent and turns into solid form, it seems to crash after a second or two.

 

Ice testing.sav


Steps to Reproduce
In the save I've attached, simply connect the gas pipe from the Thermo Regulator, to the pipe leading to the vent above. it should crash if the airlocks are closed when the oxygen freezes, but can sometimes be fine if they are open. Otherwise, to do it yourself just loop a Thermo Regulator back into itself till the gas hits -268.15°C, then add a pipe leading to a vent.

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug


User Feedback


....

As far as i see, your scenario is crashing because of pressure. You have 2 tiles for the frozen oxygen, and it will fall on the 23C 400kg mass insulated pipe that will melt your frozen oxygen into liquid then gas state. Liquid wouldnt be a problem since you can store ~800kg on 1 tile but as gas you are capped around 2kg/tile (at least what comes from vent or melts).

Also your chamber have doors which doesnt insulate heat at all. (doesnt matter in the current situation because the warm pipe will melt the oxygen anyway but for later testing :) )

Share this comment


Link to comment
Share on other sites
....

As I said before, the game still sometimes crashes while the doors are open. the ice was also coming out as ice, instead of cold air or liquid, because it was still cold enough to be ice.

Not only that but any amount of testing your assumptions would have shown that it's actually coming out even colder than it started. and dropping out as -268.83. rather than being warmer like you claimed.

And the crash happens with the room as nothing but vacuum. so it's it can't be from over pressure

Edited by Zelitor
More info

Share this comment


Link to comment
Share on other sites
....

Well, when i fixed the chamber walls, and sent out the frozen oxygen in 1 10kg blob so the pipe wont heat up too much of it, then it didnt crash and the ice was sitting there peacefully.

Share this comment


Link to comment
Share on other sites
....

I have the same problem with mine.  My game save will run about 10 seconds before it crashes. I tried multiple starts.  Looks like it is time to start a new colony.  :(

Share this comment


Link to comment
Share on other sites
....

This same issue occurs to me as well.  As soon as my cooling system hits the point where oxygen begins to freeze I crash to desktop. This is in a sealed chamber with every block being insulated tile.  If required and helpful I will more than gladly include my save file, crash files, dxdiag and screenshots of the issue.

Edited by kamyk2000

Share this comment


Link to comment
Share on other sites
.... ....

Sure.  Here ya go.  If your aim is to look over my save and disprove the crash is from oxygen freezing, please by all means go ahead, I'd love a copy of that save that didn't crash, I was on day 100 or 200 something.

Buggy.sav

Share this comment


Link to comment
Share on other sites
....


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now