Jump to content

Atmo suit on the floor won't be swept

  • Branch: Live Branch Version: Windows Pending


There's an issue when you choose to undock atmo suit.

Here the scenario. I have 10 dock for atmo suit on one side of my base. 10 on the other side. Only 16 suits in total (8 has been initially delivered to one side, 8 to the other. On the outside, both way are linked, so a dup can go out from the left, then come back to the right, for example.

In this case, I've no more suit at the left, so I choose to undock 2 from the right, and I choose to deliver 2 suits at 2 docks at the left. The command goes, all is still OK.

But then Atmo suit are not automatically delivered. Those are ignored on the floor. (Priority is OK, all my docks are at 6, default priority everywhere is at 5).

I click on them, click sweep, and nothing happen. There's no "sweeping" icon/order that take place. Even if I use the main sweep order, at any priority. The sweep order just doesn't work, suits are not there for dups, even I can still click on it.

If I reload the game, it works as it should. The order is normally set. Suits are quickly moved to vacant docks that are waiting for them following my order.

My save joined.


Before reload. Sweep click does nothing.


After reload, it works in order.



Best regards

OxCD's Factory.sav

Steps to Reproduce
Since it works when I reload but not when I need, this is after some gameplay. So I guess there's a "no-return" point in time when this issue will appear and remain, until next reload.
  • Like 1

User Feedback

Can confirm I have same issue (build LU-365655, atmo suits in a dock that are then manually un-docked cannot be manually or automatically swept or moved).

My suggested workaround is to 'assign' the un-docked suit to a dup, at which they will attempt to swap into that suit (any dropped suits they were currently wearing will be treated normally).


Share this comment

Link to comment
Share on other sites

I too just encountered this issue on build RP-383949. I could not sweep it and it would not go to the atmo suit dock. It was essentially invisible. It had fallen from a destroyed atmo suit dock. A reload of the game resolved the issue - along with several other issues I had. :(


Share this comment

Link to comment
Share on other sites

Similar/same issue here on RP-394616: I assign a dupe to a rocket, he climbs in, still needs an atmo suit to launch, but even though I undock one from the docks nearby, nobody will deliver it to the rocket, manual sweep does nothing.  I even tried ejecting another from the docks which prevented another dupe in the area from passing back through the dock to the rest of the base.  He just sat there idle with nothing to do.  Found this bug report and tried reloading and they immediately picked up the suit and delivered it to the rocket.


Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...