Another Instanse is Already Running when Launching from Directory


SwissxPiplup
  • Branch: Live Branch Version: Windows Pending

Hi there,

I have discovered a bug when trying to launch the game using the .exe in the Steam file directory, the game will launch partially but will then crash with Steam displaying the message "Another instance is already running", to which the game will close.

I have checked my task manager and there is an instance running, but that's only the prompt telling me that an instance is running; so what I can gather from that is that the prompt that is telling me another instance is running, is the instance that's stopping it from running.5b62f8af352b8_Screenshot(4).thumb.png.3fc12a970518ee1ab67369590c92c7e6.png

I can confirm this only happens when launching from the directory; launching through the Steam library works as intended.

I use a software called VoiceAttack in which you use spoken commands to perform actions, I created a command to run the game when saying "Run Oxygen Not Included", however, the command requires the executable to launch as it can't press the play button in the Steam library.

I have tested opening other games using this method and they all work as intended, isolating this to Oxygen Not Included; additionally opening the game from the directory while Steam is closed will boot up Steam and load the game correctly with no issue, it's only when loading the game from the directory while Steam is open, that this issue arises.

Steam thread here: https://steamcommunity.com/app/457140/discussions/3/1739964766309777038/

It goes into more depth on the matter and my reasoning for opening the game that way.

Thank you!


Steps to Reproduce
Ensure Steam remains open throughout all of these steps: - Right click on Oxygen Not Included in your Steam Library; - Select "properties"; - Open the local files tab; - Click on "Browse local files"; - Double click on OxygenNotIncluded.exe


User Feedback


Have the same problem, worked after install, but game just crashed after an hour right out to desktop, Tried reinstall the game, and I could start the EXE once and game crashed again after an hour. Now I started it fromSteam, and it starts (without reinstalling), lets see if it crashes after a couple of hours.

 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now