Version mismatch when connecting a slave to the master


roxservers
  • Closed

I created a DST dedicated server on a dedicated box, everything works fine.

Then I set it up as master shard (still works fine)

Then I created a second dedicated server on a different dedicated box using the exact same (and up to date) files grabbed via steamcmd. As soon as the slave shard is connected to the master I am no longer able to join in game (receiving a version mismatch error). I checked my client version and servers version, they are identical.

I used to do the same setup some time ago when game was still using settings.ini instead of cluster.ini and never had issues.

 

Cluster.ini files

Master:
http://pastebin.com/1EYnFRhh
Slave:
http://pastebin.com/A1VRfRNG

 

 

Logs:


Master:

http://pastebin.com/ELbDjMtD

Slave:

http://pastebin.com/xDWE7H3a

 

Ip's were replaced on purpose by X.X.X.X

 

Any help appreciated. 


Steps to Reproduce
Set up a master and slave shard dedicated servers on dedicated boxes.


User Feedback


if this is in the Linux shell you can try this cmd  from your steamcmd folder

./steamcmd.sh +login anonymous +force_install_dir /home/dst/server_dst +app_update 343050 +quit

Be sure that you have shut down the servers with ctrl C before doing so and restart them after.  according to your logs  - it looks like they are properly connected to each other , so you may also want to verify the integrity of your install as well you can do that by right clicking on the game in your library > properties > local files > VERIFY INTEGRITY OF GAME CACHE...

doing that will force any updates needed ( or at least it should)

Share this comment


Link to comment
Share on other sites

I did the steam update numerous times (I'm on windows) as well with validate to check files integrity with no luck. Server logs are showing correct up-to-date and matching with my client build number.

Using the same files with a single (no shard) server works just fine and lets me connect.

 

Here is the client log:

http://pastebin.com/jEpWSXB2

 

thank you

 

Share this comment


Link to comment
Share on other sites

@roxservers You're trying to run with the same port number for your server_port (via the -port command line switch) and your master_port (via the [SHARD] / master_port setting). These need to be different, at least on the master server. You can find a more detailed explanation of the server settings and command line options here:

http://forums.kleientertainment.com/topic/64552-dedicated-server-settings-guide/ 

http://forums.kleientertainment.com/topic/64743-dedicated-server-command-line-options-guide/

The easiest fix would be to change the master_port in each cluster.ini to 10888. Note that if you have a firewall on your master server, you'll have to make sure this port is open so that the slave shard can connect to it.

Share this comment


Link to comment
Share on other sites

Thanks, you have been really helpful. For some reason that setup was working on previous versions but not anymore. As the error message was confusing (version mismatch) I was not even suspecting a port issue.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now