Sign in to follow this  

Unable to upload mod


Jupiters
  • Pending

Many were suffering from this problem since yesterday.

446bc67b24892c81.png


Steps to Reproduce

Just uploaded the mod the old way.

Sign in to follow this  


User Feedback


can you upload the logfile found at C:\Users\<YourUsername>\AppData\Local\Don't Starve Mod Uploader\ModUploader.log when this occurs next?

  • Like 1

Share this comment


Link to comment
Share on other sites
1 hour ago, zarklord_klei said:

can you upload the logfile found at C:\Users\<YourUsername>\AppData\Local\Don't Starve Mod Uploader\ModUploader.log when this occurs next?

I also encountered this kind of problem. This is the most recent log.

ModUploader.log

1 hour ago, zarklord_klei said:

can you upload the logfile found at C:\Users\<YourUsername>\AppData\Local\Don't Starve Mod Uploader\ModUploader.log when this occurs next?

This is the log of another friend of mine.

ModUploader.log

Share this comment


Link to comment
Share on other sites
6 hours ago, zarklord_klei said:

The error in the log is a generic error for when steam is having problems, just try again later 

I have tried for two days. Any solution please?

Share this comment


Link to comment
Share on other sites
1 hour ago, zarklord_klei said:

please upload the log file at "C:\Program Files (x86)\Steam\workshopbuilds\depot_build_322330.log"

sorry for the newb post but I cant find workshopbuilds in my Steam folder

This is the (unzipped) folder I am trying to upload using the DST Mod Tool. I have selected DST from the dropdown. The mod is to change the story time told by Walter (1 item in the array intended)

PracticeStory.zip

Share this comment


Link to comment
Share on other sites
11 minutes ago, Purple Squirtle said:

sorry for the newb post but I cant find workshopbuilds in my Steam folder

This is the (unzipped) folder I am trying to upload using the DST Mod Tool. I have selected DST from the dropdown. The mod is to change the story time told by Walter (1 item in the array intended)

PracticeStory.zip 607 B · 0 downloads

Can you upload C:\Users\<YourUsername>\AppData\Local\Don't Starve Mod Uploader\ModUploader.log then?

  • Like 1

Share this comment


Link to comment
Share on other sites
On 3/20/2021 at 5:34 AM, zarklord_klei said:

Looks like a steam issue, best I can suggest is to try again later.

After the "Publish Error" notice, a empty name of V1 mod with the status of hidden appeared in my mod list.

image.thumb.png.02345a4b9adcdecea6ae26954cb3d5a2.png

It seemed that the mod uploader tried to upload mod to V1 workshop which was not available.

ModUploader.log

Edited by Jupiters

Share this comment


Link to comment
Share on other sites
2 hours ago, Jupiters said:

After the "Publish Error" notice, a empty name of V1 mod with the status of hidden appeared in my mod list.

It seemed that the mod uploader tried to upload mod to V1 workshop which was not available.

It's actually just how it publishes the item, first it creates an empty item, then it fills out that item with data, seeing your log, there is two possibilities, the preview image is too large(an issue I have seen occur a couple times), you can test for this by uploading with a blank/really small preview image, or unicode support for file paths isn't working quite right, because according to the log C:\Users\À±½·Ð¡~1\ is your users directory, which doesn't seem right to me.

  • Like 1

Share this comment


Link to comment
Share on other sites
1 hour ago, zarklord_klei said:

It's actually just how it publishes the item, first it creates an empty item, then it fills out that item with data, seeing your log, there is two possibilities, the preview image is too large(an issue I have seen occur a couple times), you can test for this by uploading with a blank/really small preview image, or unicode support for file paths isn't working quite right, because according to the log C:\Users\À±½·Ð¡~1\ is your users directory, which doesn't seem right to me.

I tried to upload a very small picture, but still the same error. The user directory of mine is Chinese so that it displayed À±½·Ð¡~1. But I have also tried in another computer with English user directory and it still did not work.

Everything went fine before the QoL update of March. I am pretty sure that the delevoper modified part of the mod uploader, which caused problem. Please know that I am not the only one who has encountered this bug.

Share this comment


Link to comment
Share on other sites
26 minutes ago, Jupiters said:

I tried to upload a very small picture, but still the same error. The user directory of mine is Chinese so that it displayed À±½·Ð¡~1. But I have also tried in another computer with English user directory and it still did not work.

Everything went fine before the QoL update of March. I am pretty sure that the delevoper modified part of the mod uploader, which caused problem. Please know that I am not the only one who has encountered this bug.

 

On 3/19/2021 at 5:25 PM, zarklord_klei said:

Can you upload C:\Users\<YourUsername>\AppData\Local\Don't Starve Mod Uploader\ModUploader.log then?

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites

I'm very silly and asked for the wrong file, I need this one:
C:\Program Files (x86)\Steam\workshopbuilds\depot_build_322330.log

  • Thanks 1
  • Potato Cup 1

Share this comment


Link to comment
Share on other sites

Just a thought, could it be an issue with internet connection? You can try using a vpn or web booster to help the app connect to steam workshop more easily or check if it's just blocked by firewall.

Share this comment


Link to comment
Share on other sites
15 hours ago, zarklord_klei said:

I'm very silly and asked for the wrong file, I need this one:
C:\Program Files (x86)\Steam\workshopbuilds\depot_build_322330.log

Here is the whole content of depot_build_322330.log.

[2021-03-22 19:38:27]: Building file listing for depot 322330 ...
[2021-03-22 19:38:27]: WARNING: Local mapping C:\Users\Jupiter\AppData\Local\Temp\ugcuploader_0000000090faf772_1616441907533 does not exist!
[2021-03-22 19:38:27]: Found 0 files for mapping: C:\Users\Jupiter\AppData\Local\Temp\ugcuploader_0000000090faf772_1616441907533  -> .
[2021-03-22 19:38:27]: ERROR! Build for workshop item has no content
[2021-03-22 19:38:27]: ERROR! Failed building file list

 

Share this comment


Link to comment
Share on other sites
2 hours ago, Jupiters said:

Here is the whole content of depot_build_322330.log.


[2021-03-22 19:38:27]: Building file listing for depot 322330 ...
[2021-03-22 19:38:27]: WARNING: Local mapping C:\Users\Jupiter\AppData\Local\Temp\ugcuploader_0000000090faf772_1616441907533 does not exist!
[2021-03-22 19:38:27]: Found 0 files for mapping: C:\Users\Jupiter\AppData\Local\Temp\ugcuploader_0000000090faf772_1616441907533  -> .
[2021-03-22 19:38:27]: ERROR! Build for workshop item has no content
[2021-03-22 19:38:27]: ERROR! Failed building file list

 

This is odd, its looking in C:\Users\Jupiter\ for the mod upload, yet it was that weird directory according to the mod uploader.

  • Like 1

Share this comment


Link to comment
Share on other sites
4 hours ago, zarklord_klei said:

Can you tell me if the mod tools update today has resolved this issue?

Now I could upload mod using an English name of user folder, still failed in Chinese name.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now