Jump to content

Help: Console commands


Recommended Posts

You can try a command like:

c_spawn("shovel").components.finiteuses:SetUses(<amount of uses it should have left>) 
-- or
c_spawn("shovel").components.finiteuses:SetPercentage(0.5) [[(for 50% durability)]]

for tools. Iirc for weapons you have to do an additional .weapon in the command like

c_spawn("spear").weapon.components.finiteuses:SetUses(<amount of uses it should have left>) 
--or 
c_spawn("spear").weapon.components.finiteuses:SetPercentage(0.5) [[(for 50% durability for example)]]

For spoilage I'm not really sure, but you could try something like

c_spawn("meatballs").components.perishable.SetPercent(0.5) [[50% spoiled for example]]

 

Link to comment
Share on other sites

10 minutes ago, WesleyT245 said:

I was tired of summoning treegaurds

If you just want to prevent Treeguards from spawning you can simply disable their spawns like this:

TheWorld.topology.overrides.liefs = "never"
c_save()
c_reset()

Afaik even chopping small trees spawn Treeguards, so if that's the only reason why you want only small trees, it'll prob not work.

Link to comment
Share on other sites

2 hours ago, WesleyT245 said:

It doesn't seem like the weapon ones are working. They are still spawning 100% ones.

Try running the weapon one with

c_spawn("spear").components.finiteuses:SetPercentage(0.5)

(without the .weapon). Maybe I remembered it incorrectly, and it's the same as normal tools.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...