Sign in to follow this  
lukasek

character mod - basic problems

Recommended Posts

lukasek    0
Posted (edited)

Hello there everyone.

I'm currently working on my first character mod... Despite using few different guides, and "borrowing" code from other DS files and/or other mods, still not everything works as i would like to... I'm hoping someone might be able to help me...

1) problem I've encountered is that when i made a custom weapon/tool for my character it doesnt appear in game... (all descriptions and inventory icons work fine, also i can equip tool and use it on environment, but its invisible, and when i drop it on floor it vanishes). I believe my code is ok, and problem lays in graphics. Im using TEX tools that i downloaded from this site to made graphics for my tool. Is there some codec or dll i need additionally to the tools itself to make working .tex files? Cuz icons i have edited work fine, just animated stuff doesnt seem to work.

2)  I want my character to be able to create custom items (like wickerbottom). Coding works very well and everything works peachy, but i dont know how to edit craft menu icons, and after I merged few similar items into one file its no longer showing icons of items in inventory (however game models work ok).

Could someone tell me what am i doing wrong?

Im adding some of my files as reference  

less.lua

survivalguide.lua

survivalknife.lua

survivalknife.zip

swap_survivalknife.zip

Edited by lukasek

Share this post


Link to post
Share on other sites
K1NGT1GER609    95

I can't really work with only this, I'm assuming you borrowed some weapons and reskined them. If so the setbank would be the previous weapon's build as problem 1 sounds like you got the wrong bank named. For problem 2 im not sure what you mean, you talking about making crafting recipes? crafting tabs?

Share this post


Link to post
Share on other sites
lukasek    0
Posted (edited)

1) about knife... i've change the build.bin file, and replaced the original files name with my new items name. Is there something more i should have done? I've already made a character graphics (basically copied woodies template, but ive renamed all the files in the same way, and it works ok).

Additionally ive tried to simply put a renamed axe graphics in place, and it didn't work as well... i suspect it might be the code... however i cant figure out what might be a problem with it...

2) I created a new tab in hud, and added few items to that tab so my character can create them, but despite everything working properly, the icons doesnt show (in craft tab i see those items as firepit, torch etc. and in inventory its a blank slot (i have to guess where everything is)... it is not tracking my texture files even though ive named everything correctly, I would like to add imege path line to script but all the variations ive used on survivalguide file simply had no effect at all or crashed the game upon loding. i included all the files with this post including scripts and graphics so everyone can take a look at them...

If you need any more information just write what i haven't posted and i'll give all the answers i can (its difficult to write a book in the first post of how i started and what exactly i've done, step by step from the beginning ;) ), also i didn't want to scare anyone with posting to long post, and probably writing many useless stuff that didn't possibly had anything to do with difficulties im experiencing...

DS problem 01.jpg

DS problem 02.jpg

DS problem 03.jpg

Edited by lukasek

Share this post


Link to post
Share on other sites
K1NGT1GER609    95

Lets see theres an error on the survival knife:

anim:SetBank("wand")--one of my melee weapons bank
    anim:SetBuild("wand_g") --ditto

anim:PlayAnimation("idle", true) -- you closed the parenthesis on true

So the anim's are just examples of a overwritten equippable item, so I'm guessing change the setbank to whatever you overwritten (im guessing Lucy_axe) since you can't overwrite the scml bank build with the buildrenamer (heh the name gives it away build rename not bank rename).

According to your recipe code you haven't declared where to find the atlas of the item in the crafting tab so don't starve will choose a random atlas everytime so heres an example of a recipe code:

local armor_device = Recipe("customitem", { Ingredient("goldnugget", 35), }, RECIPETABS.REFINE, {REFINE=0})
armor_device.atlas = "images/inventoryimages/customitem.xml"

So maybe change it to like so:

local survivalguide1 = Recipe("survivalguide_01", { Ingredient("twigs", 1), }, booktab, {SCIENCE=0})
survivalguide1 .atlas = "images/inventoryimages/survivalguide_01.xml"

Share this post


Link to post
Share on other sites
lukasek    0

Hi,

Actually i already fixed the recipe problem... i chose different solution, but it works...

Now about weapon... ive already did all of that months ago... (i working on this mod for about half a year... just havent got a lot of free time to do it quickly)... I applied many different build sets... i exchanged files in weapon pack it still doesnt work... Everything ive done, according to everything there is suggest it should be working... but it does not... im at loss... Im still thinking that there is some sort of video codec that is required to edit those files and when you do it without it it breaks everything... :/

Share this post


Link to post
Share on other sites
K1NGT1GER609    95

I noticed swap_survivalknife is missing the anim binary file so put that back in and I'm going to take another guess and say did you have these settings for tex tool: pixel format dxt5, texture type: 2d, mipmap resize filter: default, check on both generate mipmaps and pre-multiply alpha. Since there are two texture converters and using textool1.2.0 isn't efficient enough and doesn't have the right settings. Other wise shall I suggest another the wand mod to make your machette?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this