Jump to content

Issues downloading mods, not the regular...

Recommended Posts

I appear to have correct permissions, I can delete and add new files at will. However files will not update or download from the workshop. I have tried entering safe mode, and reinstalling the game (using both steam and deleting all the folders). Nothing has worked so far. This bug began with the new Forge Update. If there is a known fix I would love to be informed.

Steam downloads workshop items for other games and can even download the same mods when I set up a dedicated server on the same computer, yet they refuse to download for DST. Steam says it downloads all the mods but when I get in game it says that they're downloading. Then it goes away, like it gave up for a moment, before starting the download again... Upon further investigation I noticed that this occurs for both DS and DST. Also this happens on another computer in my house with a fresh install of steam....

I've reinstalled the game 3 times now and can't figure out what the problem is...

I haven't seen or heard of anyone else with this exact problem and help would be appreciated.

Link to comment
Share on other sites

54 minutes ago, Dreamscape18459 said:

How are you running the dedicated DST server? Is it through the Steam client or Steam CMD?

I ran the dedicated through steamcmd and It downloaded mods without problem, or at least most of them, I did have an error related to some mods being client only, but that seems unrelated.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...