Jump to content

What's up with the lies and incompetence ?

Recommended Posts



BOTH POST FROM YEARS AGO .. Look how they tried to hide it as if it was "solved"!? Lol PATHETIC.


TL;DR; Klei workers are incompetent , liars and very rude. If you're hoping for actual help, then you WONT find it here.

Let me just start this off by saying it's been so long now , this was SAD to see from mods trying to hide my post to admins ignoring the entire situation and then LYING ABOUT IT ...

I quit this game because of the incident that happened a year ago , the customer support was horrid and honestly I was let down by Klei..


i came back hoping , you know they actually followed through but ofcourse .. Not.

Sh***** morals for a well loved franchise.


heres a repost from the post I made about a year ago it actually got pretty popular, NEVER did anyone resolve this besides telling us to do a bunch of random SH**** that didn't help at all which we told them time and time..

its been a year now, I think longer ...

its safe to say klei is one of the LAZIEST and WORST mods/customer support.



Look , I tried posting it under shipwrecked bugs, It does not let me. Option is greyed out. Now I don't think its too much to ask for an answer here. Which I will . Once again . Since I've seen a nice amount of them already posted here and .. Answered . So I'll attempt this again in hope an admin , answers with intentions to help.


Okay so I just purchased Shipwrecked DLC today at 7PM EST with my girlfriend because out of all the crazy games I play she actually likes this one very much .. Point been is , we spent hours died a few times of course and finally nailed it on one character day 28 exploring the seaaas. We found a freaking volcano. Excited i jumped in and... That was my mistake.. (WHICH SHOULDNT BE).. Game crashed gave me CE-34878-0 error.. Okay cool . Let me just load it again . Nope . Great. Wasted 6 hours for ... Nothing (I reloaded it almost 10 times and reset my ps4 twice..) I couldn't even die to get the EXP and quite frankly I barley wanna touch the game again. Btw this was ps4 NO MODS whatsoever, I'm not even sure how this happened but anyways. Hopefully this is fixed in the next patch, I won't delete this save because my girlfriend is more disappointe than I am and wanna be optimistic here . Just pointing this out since ps4 seems to not get lots of bug reports thanks for reading this very frustrating experience. 


Psn - MangoTangoO



Link to comment
Share on other sites

As far as we are aware, this issue has been addressed. If you have a very old save that was broken by this bug, unfortunately; there isn't anything we can do about it. 

Otherwise, if you are having this issue currently, on new saves; this is not something I am aware of, so I will have to see what we can find out. 

Regarding your complaints about how the issue was handled, if you have specific instances where you feel like somebody was being rude to you, or not handling your issue appropriately, please let me know and we'll take a look. 


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...