Jump to content

[Solution] Ping showing as '???'

Recommended Posts

I recently opened up my own dedicated server, but I find that no one would join. The problem was that my ping showed up as '???'. 

I went and do my research on how to fix this..So here is my take on how I fixed it.

  • Check your dst command prompt(the DST_null thing that would come up when starting the dedicated server) for port. Anything that resembles the number of port or anything that have number after the word port you should take a note of it for port forwarding.
  • Make sure you know how to port forward. I'm not gonna get into this, the information are out there and everyone has a different router. Also make sure you port forward with the right local IP address 
  • Run the start dedicated server .bat file as administrator. I use the .bat dedicated server tutorial for this I'm sorry I don't know if I can help if you created dedicated server in a different way, but I imagine if you port forward and run your start up as administrator it might help.

In conclusion, I basically took a note of every port numbers I find and forwarded them all, then I run my server as administrator. Anyway if you guys are able to pin point which port should be forwarded be sure to let me know, in the mean time I will try to figure it out too.

Link to comment
Share on other sites

Ok, I've got news.
Some minutes ago, i tried one more time to make the ping in my dedicated server appears (port fowarded the master's port -> 10999 UDP), and ... 


It worked!
Turns out either my old router or my old modem was the culprit of it, i had to change them after messing with the router's software d:
With my new router/modem port forwarding worked like a charm! (I have no ideia why, since it's a really cheap piece of hardware...)

In short: 
When your dedicated server's ping is appearing as "???" in the online tab, it means something is blocking Klei from directly pinging it.
Usually, port forwarding the Master's port - That is usually the port 10999 udp - will resolve this issue.

Here is where you can check which port your Master uses:

If port forwarding does not resolve this issue, something else is blocking Klei from pinging you, but it's hard to guess what.
In my case it was probably my router - maybe my modem - that was making this issue happen. 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...