Sign in to follow this  
DoISeeColor

Lua files for mods overwritten on server startup

Recommended Posts

DoISeeColor    4

Sorry for the wall of text ahead of time, please bear with me if you might know anything about the issue!  :p

So I've been having a bit of a weird issue with trying to get server-side mods working on my dedicated server.  Every time I start my server, my modsettings.lua and dedicated_server_mods_setup.lua in \steamcmd\steamapps\common\Don't Starve Together Dedicated Server\mods gets overwritten, so no mods will load on my server.  

I've tried going through the full setup, adding the mod to dedicated_server_mods_setup.lua, ForceEnable in modsettings.lua, double checking that when I boot up DST, that the server mods section shows that they are all enabled, adding to the modoverrides.lua in /Documents/Klei/DontStarveTogether/MySever/.  No matter what I do, those files get overwritten and I get no mods.

Recently when attempting to get the Finder mod to work, I found that when clicking inside the console window during startup of my server, it will actually pause the startup until I hit enter again.  This proved advantageous as I was able to pause after the files got overwritten, which occurs in the early phases of starting the server, prior to it launching the two console windows, one for my overrworld and the other for my caves.  When I pause my startup at this point in the startup, my files have already been overwritten:

[  0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Connecting anonymously to Steam Public...Logged in OK
Waiting for license info...OK
 Update state (0x5) validating, progress: 0.00 (0 / 828583173)
 Update state (0x5) validating, progress: 7.28 (60302008 / 828583173)
 Update state (0x5) validating, progress: 15.62 (129421405 / 828583173)
 Update state (0x5) validating, progress: 52.68 (436532349 / 828583173)
 Update state (0x5) validating, progress: 70.15 (581226726 / 828583173)
 Update state (0x5) validating, progress: 71.37 (591383900 / 828583173)

If I re-save my changes to the files before the next step, it will try to download the mod(s) I specify, but they have not yet worked on my server thus far.

[00:00:01]: DownloadMods(1)
[00:00:01]: Download server mod 786654500
[00:00:02]: FMOD Error: An invalid object handle was used.
[00:00:02]: LOADING LUA SUCCESS
[00:00:02]: PlayerDeaths could not load morgue
[00:00:02]: PlayerHistory could not load player_history
[00:00:02]: bloom_enabled       false
[00:00:02]: loaded saveindex
[00:00:02]: OnFilesLoaded()
[00:00:02]: OnUpdatePurchaseStateComplete
[00:00:09]:     Load FE
[00:00:50]:     Load FE: done
[00:00:50]: ModIndex: Load sequence finished successfully.
[00:00:50]: Reset() returning
[00:00:50]: [200] Account Communication Success (6)
[00:00:50]: Received (someToken) from TokenPurpose
[00:00:50]: Starting Dedicated Server Game

I run my dedicated server locally on my windows machine. I followed the guide on these forums to get everything setup, so I only have limited knowledge about my setup.

I'm at a loss for what to do about this issue.  I feel like I'm to just go on without any server-sided mods, but I'd like to play around with some of them!  Any help will be very much appreciated! :D

Edited by DoISeeColor

Share this post


Link to post
Share on other sites
alainmcd    901

Try removing "validate" from the first line of your batch file (step 11 in the guide you linked), it'll look something like this:

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 +quit
cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Master
start dontstarve_dedicated_server_nullrenderer -console -cluster MyDediServer -shard Caves

The logic:

Spoiler

When Steam updates an installation, it checks for new files and files that have changed, and downloads them. When you validate, it checks all installation files and redownloads the ones that do not match the original files. Since you need to edit dedicated_server_mods_setup.lua and modsettings.lua which are part of the original installation, they are redownloaded and your configuration is lost. Validation is only needed if your installation becomes corrupt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this