Jump to content

Character Conflict - I just can't fix this

Recommended Posts

Hi again!

This is a really weird problem here. I made two custom characters with the same abilities, same recipe tab (Male&Female), except that I changed every name in lua files to fit the corresponding character. When it comes to play, I activate the male character, the recipe tab is working. But when I activate the female character, going in game with the male again, the custom recipe of the male character is not working, but the recipe is working on the female character instead. As if the second of them is overwriting the other modmain or something like that. The female is always working, the male depend on if the female is on or off...

The female name begins with A, the male name begins with H; is there any alphabetical priority or what? The game loads recipe of A, when it comes to H he "believes" he already loaded it? Dahhh!

The modmain are the same on each side as they are the same character. Their folders are structured in the same way. I tried to code a different recipe on the first character but it did not work.

What should I do ? My recipe looks like this in short, both side. Simply changed "ada".


local Ingredient = GLOBAL.Ingredient

RECIPETABS['ada_TAB'] = {str = "ada_TAB", sort=1000, icon = "adatab.tex", icon_atlas = "images/recipe_tab/adatab.xml"}
STRINGS.TABS.ada_TAB = "Nature Wisdom"

local whitepotion_recipe = AddRecipe("whitepotion", {Ingredient("seeds", 2), Ingredient("nitre", 2)}, RECIPETABS.ada_TAB, TECH.NONE , nil , nil, nil, nil, "ada" , "images/inventoryimages/whitepotion.xml")



Link to comment
Share on other sites

Hmm, maybe two characters using the same crafting tab just won't work for some reason? Have you tried just copying the whole tab and just changing the name (I think you have it called "ada_TAB" there, maybe call it something like ada_TAB2) and let your characters use their seperate? Like the male would use "ada_TAB" and female "ada_TAB2".

Link to comment
Share on other sites

Thanx for helping me out!

The female tab is called ada_TAB and the male is hadabra_TAB. How can they be using the same crafting tab at first? They seem different to me. I changed ada_TAB to ada_TAB2, but still, the male tab did not work when the female was enable. I tried to change the male crafting tab a complete different name, it did not work. When the female is enable, I can't see the male recipe tab, whatever the name I give to it. That's why I tried to code a new recipe for the male. The code was not the same, but it was still conflicting with the female version.

What if the problem was not from the recipe tab? I dunno...

Every assets that load are the same; same name, same directory, etc. Could this be the problem here? Should I change every item/folder names?

Changed every item names and it works back. The tab is the same; problem came from using same prefab names.

Edited by D4rkh0bb1T
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...