Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

LichBs

Server token

Recommended Posts

LichBs    0

I have this problem 

  • [00:00:00]: DownloadMods(0)
    [00:00:00]: FMOD Error: An invalid object handle was used. 
    [00:00:01]: LOADING LUA SUCCESS
    [00:00:01]: PlayerDeaths could not load morgue    
    [00:00:01]: PlayerHistory could not load player_history    
    [00:00:01]: bloom_enabled    false    
    [00:00:01]: Could not load saveindex    
    [00:00:01]: OnFilesLoaded()    
    [00:00:01]: OnUpdatePurchaseStateComplete    
    [00:00:01]:     Load FE    
    [00:00:01]:     Load FE: done    
    [00:00:01]: ModIndex: Load sequence finished successfully.    
    [00:00:01]: Reset() returning
    [00:00:03]: [200] Account Failed (6): "E_INVALID_TOKEN"
    [00:00:03]: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [00:00:03]: !!!! Your Server Will Not Start !!!!
    [00:00:03]: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [00:00:03]: No auth token could be found.
    [00:00:03]: To generate a cluster_token you must
    [00:00:03]: open the console from a logged-in game
    [00:00:03]: client with the tilda key (~ / ù) and type:
    [00:00:03]: TheNet:GenerateClusterToken()
    [00:00:03]: This will create 'cluster_token.txt' in
    [00:00:03]: your client settings directory. Copy this
    [00:00:03]: into your cluster settings directory.
    [00:00:03]: [Connect] PendingConnection::Reset(true)
    [00:00:05]: Collecting garbage...
    [00:00:05]: lua_gc took 0.01 seconds
    [00:00:05]: ~ShardLuaProxy()
    [00:00:05]: ~ItemServerLuaProxy()
    [00:00:05]: ~InventoryLuaProxy()
    [00:00:05]: ~NetworkLuaProxy()
    [00:00:05]: ~SimLuaProxy()
    [00:00:05]: lua_close took 0.02 seconds
    [00:00:06]: CurlRequestManager::ClientThread::Main() complete
    [00:00:06]: HttpClient2 discarded 0 callbacks.
    [00:00:06]: Shutting down
     
  • I use Windows 
  • I try all from this link but is still don't work ... someone help me 

Share this post


Link to post
Share on other sites
Zillvr    1,594

@LichBs if you followed the Quick Setup Guide to the letter, everything should work. The only possibility of it not working is that you might not have generated and/or saved the correct cluster_token in a .txt. Which is Step 5 and Step 6 in the guide. 

Share this post


Link to post
Share on other sites
Zillvr    1,594

@LichBs can you double check whether or not there is a space at the end of your saved token in cluster_token.txt placed under Documents\Klei\DoNotStarveTogether\MyDediServer. Make sure there is no space after the last letter of the token.

Share this post


Link to post
Share on other sites
Zillvr    1,594

Did you click Generate Server Token in the Acct Info steam overlay pop up, and copy the newest generated token that has the description of Web Admin Generated?

Share this post


Link to post
Share on other sites
ToNiO55    297

problem is fixed for LichBs, he have just not put cluster_token.ini in good path directory

Documents\Klei\DoNotStarveTogether\MyDediServer\cluster_token.txt

Share this post


Link to post
Share on other sites
ChromeSpear    0

I attempted to create my server, but I still get the same error over and over again: "E_EXPIRED_TOKEN". I followed all the steps in the same guide LichBs used, I followed it to the very letter! I have many different folders in my DoNotStarve folder, many of which are Cluster files. What should I do? I have found so many guides on the internet, I searched the DST Wiki, the Steam forums, even the Klei forums as well!

Share this post


Link to post
Share on other sites
Zillvr    1,594

Hey @ChromeSpear welcome to the forums, most likely your issue is only with the placement of your files. When you create the files for your dedicated server, you'll end up with 6 new files that will all be placed under Documents\Klei\DoNotStarveTogether. In the Quick Setup Guide, step 12 shows all the files you'll need at the end of the guide for the dedicated server to work. 

If you're getting E_EXPIRED_TOKEN, then you'd just have to repeat steps 4, 5 and 6 in the guide.

Share this post


Link to post
Share on other sites
ChromeSpear    0

I have put my files in the correct places, but there are other folders outside of "MyDediServer", should I delete them? I think that they might be the problem, because I have a server token and other junk, like many other cluster folders. I have no idea what to do with that stuff, seeming as this is my first time working on making a dedicated server for DST or any game for that matter. 

Share this post


Link to post
Share on other sites
Zillvr    1,594

@ChromeSpear The other folders are not an issue cause they are not junk and are necessary files for the game itself to run. Are you getting the E_INVALID_TOKEN when you start up the server? Can you attach your server_log.txt found under Documents\Klei\DoNotStarveTogether\MyDediServer\Master?

Share this post


Link to post
Share on other sites
ChromeSpear    0

I am getting either one, "E_INVALID_TOKEN" or two, "E_EXPIRED_TOKEN". I don't know whats up, but thanks for telling me the other folders aren't junk and are necessary for the game to run. I never knew that, but still I am lost, as I have said before, I have tried many different guides and still haven't found the answer to my questions.

[200] Account Failed (6): "E_INVALID_TOKEN"
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!! Your Server Will Not Start !!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
No auth token could be found.
To generate a cluster_token you must
open the console from a logged-in game
client with the tilda key (~ / ù) and type:
TheNet:GenerateClusterToken()
This will create 'cluster_token.txt' in
your client settings directory. Copy this
into your cluster settings directory.
[Connect] PendingConnection::Reset(true)

Share this post


Link to post
Share on other sites
ToNiO55    297

Hi @ChromeSpear

how do you have generate your token?

with account info in game? or with this command TheNet:GenerateClusterToken() ?

your server_token is here?

\Documents\Klei\DoNotStarveTogether\MyDediServer\cluster.ini

you have check there is no space when you have paste your token in your server_token.txt?

and as says Zillvr, can you share all of your server_log.txt please

\Documents\Klei\DoNotStarveTogether\MyDediServer\Master\server_log.txt

Share this post


Link to post
Share on other sites
ChromeSpear    0

Hey @ToNiO55 , you generate a server token in game by going to Acct Info button and then click the button that says generate server token. I have attempted using the command but it hasn't worked for me except for one time it worked. I have no space when I pasted the server token. There wasn't an instruction that said you have to make a new text document labeled server_token.txt, but there was a cluster_token.txt.

Share this post


Link to post
Share on other sites
ToNiO55    297

@ChromeSpear

i know about token, because my server_token.txt works on my all dedicated server

there is necessarily a mistake, creating, or encoding, or location of your server_token.txt

trying to create the file again with the token

if it's still not working, and if you agree i can testing your token on my dedicated server test

of course if you interesting, give me your token with private message

Share this post


Link to post
Share on other sites