Can't get mods to load/work on ded server


Recommended Posts

Setting up a ded server on an extra PC at home.  Can get the server up and running, but I can't get workshop mods to load/enable.

 

Setup:

--------

- Win 7

- Installed DST dedicated server from Steam Tools download

   (I first tried the manual install of Steam CMD.  Couldn't figure out how to use it.  Then I found the tools download. Dunno if this matters)

- Using two computers and two Steam accounts (let's call them ADMIN on PC1 and PLAYER on PC2).

- Added

     return {
         ["workshop-375850593"] = { enabled = true }

     }

     to C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together Dedicated Server\mods\modsettings.lua 

- For now, I'm just trying to get one mod to work: Extra Equip Slots (id# 375850593)

- I haven't tried the force enable option yet.

 

Symptoms

-------------

- If ADMIN hosts non-dedicated server on PC1 (HOST SERVER option thru game UI), mod is available and works for everyone.

 

- If ADMIN runs dedicated server on PC1, then mod is not available for anyone.

 

- When ADMIN uses game client UI on PC1 to play the ded server game, the mods are disabled.  Manually enabling the mod has no effect.  There is no change to disable/enable status of mods for PLAYER on PC2.

 

- In one of the various iterations of changing files and such, I did see messages in the Dedicated Server command window saying that the mods were being loaded, but nothing was ever available when the game started.

 

- I do currently see these messages.  Dunno if they're significant.

[00:00:00]: loaded modindex
[00:00:00]: ModIndex: Beginning normal load sequence for dedicated server.
 
[00:00:00]: DownloadMods(0)
[00:00:00]: FMOD Error: An invalid object handle was used.
[00:00:00]: LOADING LUA SUCCESS

 

 

Questions:

--------------

#1: Am I changing the correct file in the correct way?

 

#2: What interactions are there between the config files for non-ded hosting and dedicated servers?  From what I can see, the settings.ini file in the user Klei directory is used by both non-ded and ded hosting.

 

#3: There are files named "server_save" (no extensions) in subfolders in the save directory and a folder with the session ID in the "session" directory.  These files are also created by both non-ded and ded hosting.  It appears that if these files exist, the dedicated server will use it to resume the server, even if the file was created by a non-ded server.  Deleting them will force the start of a new server.

 

#4: And, of course, the last questions is "How do I get the !$%@&^# mods to work?!"

 

Thanks in advance for your helpful replies.

Link to comment
Share on other sites

- Added

     return {
         ["workshop-375850593"] = { enabled = true }

     }

I hope I'm just misinterpreting this, but - did you add the whole thing to modsettings.lua? didn't that file already contain a return statement with opening and closing braces?

 

Actually, hang on - you probably skipped a paragraph on the wiki article.

modsettings.lua is where the ForceEnableMod statements go, the part you posted goes into modoverrides.lua.

Link to comment
Share on other sites

Thanks for the reply, Myxal.  Sorry for waiting so long to reply.  The PC I was using this for crapped the bed and I've been sorting that out.

 

Yer right, I had the wrong entries in the wrong files.  Unfortunately, I'm having a different set of issues now and am struggling with that.  I installed the ded server on a different machine but it fails trying to load the scripts/main.lua file.  Not sure what I've messed up there.

 

Anyway, thanks for your help on the mod settings.  When I get back to the point of enabling mods, I'll let you know if this resolved my issue.

 

Have a good 'un.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.