Jump to content

How to LAN on Wifi

Recommended Posts

Using two laptops A & B (with wifi, windows 8) in the same room, I started my hosted network on laptop A from command line:

  • netsh wlan set hostednetwork ssid=mynetwork key=password mode=allow
  • netsh wlan start hostednetwork

IPConfig from Laptop A revealed the network created:


Wireless LAN adapter Local Area Connection* 4:

   Connection-specific DNS Suffix  . :

   Link-local IPv6 Address . . . . . : fe80::70b9:dce4:67e3:a8a2%12

   IPv4 Address. . . . . . . . . . . :

   Subnet Mask . . . . . . . . . . . :

   Default Gateway . . . . . . . . . :


I then got the laptop B connected via wifi.


I was then able to ping both laptops from one another via command line using the IP addresses found using ipconfig.


However, I when attempting to join the game hosted on Laptop A from Laptop B, it failed.

We were both playing offline (no internet) and the game would not show up in the browser.


I tried to connect directly through the console which also didn't work (timeout error or such iirc):



Clue1: When refreshing the game browser, it would sometime show "0 results" OR other times "0/1 results".


Clue2: If connecting via Ethernet cable through router, we can see the game in the game browser and connect with no issues whatsoever.


How can I get wifi lan to work (we no longer have access to Ethernet cable and router).


Alternate solutions to using the hostednetwork are welcome, but it must be a wifi solution requiring no other hardware.

Link to comment
Share on other sites

@ezcro, Did you set the LAN filter to On in the filter panel (on the server listing screen)? It's at the bottom, so you have to scroll down.

I imagine it is set by default as we are both playing offline. We've never changed settings when connecting by Ethernet cable either and it worked fine then. Not too mention direct connect with the console didn't work (which does not take into account filters).



What is your OS?, is the same in both laptops?

Windows 8, both laptops.



In any case guys, it appeared to be working last night for some reason. However, as the problem appears intermittent I'd still welcome advice.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...