[Client Crash] - DST won't start but DS runs fine


bio636

Recommended Posts

Bug Submission:

Category: Client Crash

Issue Title: DST won't start but DS runs fine

Issue Description: I am running OSX 10.6 which Don't Starve doesn't support, but I have never had any problems running it. Don't Start Together crashes after opening in steam, and finder gives this error message.

Dyld Error Message:

Library not loaded: /usr/lib/libcurl.4.dylib

Referenced from: /Users/K2/Library/Application Support/Steam/SteamApps/common/Don't Starve Together Beta/dontstarve_steam.app/Contents/MacOS/dontstarve_steam

Reason: Incompatible library version: dontstarve_steam requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0

However when looking in the package contents, DST shows that 10.6 and above, the same for DS. Does DST have higher requirements than stand alone Don't Starve?

Steps to Reproduce: Click play in Steam.

Link to comment
Share on other sites

@bio636, It looks like it requires a newer version of libcurl, which is what's used for some of the networking, which is why it wouldn't have the same crash in single-player. It's possible it would work with your older version, too, if they changed some setting in the OS X build, but I don't really know.

Link to comment
Share on other sites

That makes sense. I hope they fix it, but I won't be holding my breath since 10.6 isn't supported so they don't really have an obligation to change anything.

 

I've been looking at a workaround by downloading libcurl 7 in a separate place and running DST through that, but ultimately I don't know enough about the terminal and curl to do it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.