Jump to content

My character isn't on?


Recommended Posts

Long story short, I made changes to my character and now she works great!

But when my friend tried to join my server, it turns out she was always missing a mod.

Turns out the culprit was my reworked character, even though i gave her the exact file she needed.

 

I don't quite understand why my mod is considered 'missing' when joining but it has my head garbled up.

Anyway heres the prefab:

local MakePlayerCharacter = require "prefabs/player_common"local assets = {        Asset( "ANIM", "anim/player_basic.zip" ),        Asset( "ANIM", "anim/player_idles_shiver.zip" ),        Asset( "ANIM", "anim/player_actions.zip" ),        Asset( "ANIM", "anim/player_actions_axe.zip" ),        Asset( "ANIM", "anim/player_actions_pickaxe.zip" ),        Asset( "ANIM", "anim/player_actions_shovel.zip" ),        Asset( "ANIM", "anim/player_actions_blowdart.zip" ),        Asset( "ANIM", "anim/player_actions_eat.zip" ),        Asset( "ANIM", "anim/player_actions_item.zip" ),        Asset( "ANIM", "anim/player_actions_uniqueitem.zip" ),        Asset( "ANIM", "anim/player_actions_bugnet.zip" ),        Asset( "ANIM", "anim/player_actions_fishing.zip" ),        Asset( "ANIM", "anim/player_actions_boomerang.zip" ),        Asset( "ANIM", "anim/player_bush_hat.zip" ),        Asset( "ANIM", "anim/player_attacks.zip" ),        Asset( "ANIM", "anim/player_idles.zip" ),        Asset( "ANIM", "anim/player_rebirth.zip" ),        Asset( "ANIM", "anim/player_jump.zip" ),        Asset( "ANIM", "anim/player_amulet_resurrect.zip" ),        Asset( "ANIM", "anim/player_teleport.zip" ),        Asset( "ANIM", "anim/wilson_fx.zip" ),        Asset( "ANIM", "anim/player_one_man_band.zip" ),        Asset( "ANIM", "anim/shadow_hands.zip" ),        Asset( "SOUND", "sound/sfx.fsb" ),        Asset( "SOUND", "sound/wilson.fsb" ),        Asset( "ANIM", "anim/beard.zip" ),        Asset( "ANIM", "anim/sakura.zip" ),        Asset( "ANIM", "anim/ghost_sakura_build.zip" ),}local prefabs = {	"book_tentacles", "book_tentacles", "researchlab3_blueprint" }local start_inv = {	-- Custom starting items	"book_tentacles" , "book_tentacles", "researchlab3_blueprint" }local tempCaveVar = false local function updatestats(inst)	if TheWorld.state.phase == "day" then			inst.Light:Enable(true)		inst.components.locomotor.walkspeed = (3.5)		inst.components.locomotor.runspeed = (5.5)		inst.components.sanity.dapperness = (TUNING.DAPPERNESS_SMALL * -5)				inst.components.combat.damagemultiplier = 0.5			   -- DAPPERNESS_TINY = 100/(day_time*15),       -- DAPPERNESS_SMALL = 100/(day_time*10),       -- DAPPERNESS_MED = 100/(day_time*6),       -- DAPPERNESS_LARGE = 100/(day_time*3),       -- DAPPERNESS_HUGE = 100/(day_time),	   -- daytime is 300	   	elseif TheWorld.state.phase == "dusk" then		inst.components.locomotor.walkspeed = (6)		inst.components.locomotor.runspeed = (7.5)				inst.components.sanity.dapperness = (TUNING.DAPPERNESS_SMALL * 3)				inst.components.combat.damagemultiplier = 1.5			elseif TheWorld.state.phase == "night" then		inst.components.locomotor.walkspeed = (7.5)		inst.components.locomotor.runspeed = (8)				inst.components.sanity.dapperness = (TUNING.DAPPERNESS_SMALL * 8)		inst.components.combat.damagemultiplier = 2		    elseif tempCaveVar == true then				inst.components.locomotor.walkspeed = (TUNING.WILSON_WALK_SPEED * 1.75)		inst.components.locomotor.runspeed = (TUNING.WILSON_WALK_SPEED * 2.5)				inst.components.sanity.dapperness = (TUNING.DAPPERNESS_SMALL * 6)				inst.components.combat.damagemultiplier = 1						endend-- This initializes for both clients and the hostlocal common_postinit = function(inst) 	-- Minimap icon	inst.MiniMapEntity:SetIcon( "sakura.tex" )	inst:AddTag("bookbuilder")endlocal function fn()	inst:AddComponent("sanityaura")	inst.components.sanityaura.aura = -TUNING.SANITYAURA_LARGE		end-- This initializes for the host onlylocal master_postinit = function(inst)	inst:AddComponent("sanityaura")	inst.components.sanityaura.aura = -TUNING.SANITYAURA_LARGE	-- choose which sounds this character will play	inst.soundsname = "willow"	-- Stats		inst.components.health:SetMaxHealth(250)	inst.components.hunger:SetMax(150)	inst.components.sanity:SetMax(200)		inst.components.eater.monsterimmune = true	inst.components.eater.strongstomach = true		--  Night-vision    inst.entity:AddLight()    inst.Light:Enable(true)    inst.Light:SetRadius(5)    inst.Light:SetFalloff(.6)    inst.Light:SetIntensity(0.9)    inst.Light:SetColour(235/255,12/255,12/255)	inst:ListenForEvent( "nighttime", function() inst.entity:AddLight() end, GetWorld() )		inst:AddComponent("reader")		inst:WatchWorldState( "startday", function(inst) updatestats(inst) end )	inst:WatchWorldState( "startdusk", function(inst) updatestats(inst) end )	inst:WatchWorldState( "startnight", function(inst) updatestats(inst) end )		updatestats(inst)	return inst	endreturn MakePlayerCharacter("sakura", prefabs, assets, common_postinit, master_postinit, start_inv, fn)

Mind you, everything works fine(glitch and crash free) so i don't quite get what i'm missing.

Link to comment
Share on other sites

As far as I know you shouldn't need to give your friend your mod manually, just go to your mod's modinfo.lua and change this:

all_clients_require_mod = false

to

all_clients_require_mod = true

Your mod should be downloaded on clients automatically after that.

Link to comment
Share on other sites

As far as I know you shouldn't need to give your friend your mod manually, just go to your mod's modinfo.lua and change this:

all_clients_require_mod = false

to

all_clients_require_mod = true

Your mod should be downloaded on clients automatically after that.

 

all_clients_require_mod = true is already marked as 'true so im confused.

I have two versions of my mod, a steam version that hasn't been reworked. And the non-steam that has been reworked.

 

Steam works fine. Rework doesn't. The only changes i've made between the two is their prefabs. So i'm just going with the assumption it's the prefab. Problem is, i can't spot it whatsoever. x_x!

Link to comment
Share on other sites

all_clients_require_mod = true is already marked as 'true so im confused.

I have two versions of my mod, a steam version that hasn't been reworked. And the non-steam that has been reworked.

 

Steam works fine. Rework doesn't. The only changes i've made between the two is their prefabs. So i'm just going with the assumption it's the prefab. Problem is, i can't spot it whatsoever. x_x!

 

I'm not sure if mods that havent been published either on the workshop or on the forums will be downloaded automatically.

I'd suggest updating the steam version with the reworked one and see if that works.

Link to comment
Share on other sites

I'm not sure if mods that havent been published either on the workshop or on the forums will be downloaded automatically.

I'd suggest updating the steam version with the reworked one and see if that works.

 

 

Huh, well that worked.

 

Problem is i don't understand why manually it didn't work.

I've done it a bunch of times with my other mods and it works no problem.

 

But with this particular mod however, I had to publish her in order for my friend to play her.

Kinda frustrating but it works, well, I ain't gonna argue.

 

Thanks!

Link to comment
Share on other sites

@rons0n, For determining the mod to enable (when matching with a server's all_clients_require_mod mod), it goes by the folder name. So if your friend ended up with a folder of a different name, it won't work. It's possible there are other things going wrong, though.

 

As a side note, I don't think you need to be loading all of those player action assets. You should be able to have just the two sakura ones at the bottom. I'm not sure that it actually makes anything less efficient to have them there, though.

Link to comment
Share on other sites

@rons0n, For determining the mod to enable (when matching with a server's all_clients_require_mod mod), it goes by the folder name. So if your friend ended up with a folder of a different name, it won't work. It's possible there are other things going wrong, though.

 

As a side note, I don't think you need to be loading all of those player action assets. You should be able to have just the two sakura ones at the bottom. I'm not sure that it actually makes anything less efficient to have them there, though.

 

Really? All those player assets came with the Extended Character Template so i didn't bother touching up on it. Well, if thats the case i'll delete them but i don't really see the problem leaving them there :p

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...