[Gameplay] - Unable to Interact w/ Environment, Inventory, Equipment or Chat After Periods of Extended Play


Recommended Posts

Bug Submission:

Category: Gameplay

Issue Title: Unable to Interact w/ Environment, Inventory, Equipment or Chat After Periods of Extended Play

Issue Description: Just enjoyed my first foray into the Closed Beta last night and had a blast playing with others, but complements aside, I did run into one major bug that required me to disconnect and reconnect to the server I was on in order to restore my ability to interact with... More or less anything!

After about an hour and a half of uninterrupted, moderately stable play (slight delay in picking up items and attacking aside) I crafted a Meat Effigy without placing it. A fellow WX-78 who had died and became a ghost floated back to our base, and I told him to use the Meat Effigy we already had set down, since I was going to place a new one.

He did so, and I went to place my own Meat Effigy once he had recovered, but after an abnormally long structure-building animation, nothing popped up. Brushing it off, I tried again once or twice with no success, and so tried to tell the others I was having trouble placing my Meat Effigy.

I could type out my message just fine, but when I would hit enter, the message wouldn't send, though I could receive messages from the others like normal. I believe my entire inventory was frozen as well, so I couldn't grab anything, either to equip, unequip, consume or otherwise use anything. I'm not sure if I was still able to craft anything, I think I tried clicking a tab on the crafting bar and it was frozen as well and would not even open.

I don't believe this was caused due to rubber banding, or if it was it was a very specific desync that prevented me from interacting with the rest of the world or even my own inventory, as I could see my companions moving and chatting at a normal pace, picking up items, all that good stuff without any irregularity in animation or speed, even I could continue running around and nothing appeared strange about my own movements, it seemed to purely be a loss of function, and only for me.

I disconnected and rejoined the server and everything was back to normal, so I placed my Meat Effigy and kept going as I had before. Another hour passed without issue, until it occurred again while I was picking berries for food. I had already picked a few bushes, and was moving to a new one, but after playing the gathering animation the interaction did not go through and the berries remained on the bush.

Just then, Hounds started to signal an upcoming attack, so I went to put on my Log Suit, only to find I couldn't interact with it, or anything else for that matter. Not wanting to be mauled in my crippled state I disconnected once again.

I rejoined later on and again, everything was back to normal, but I can at least confirm that this is a reoccuring bug, and that it can effect everything from structure placement to personal inventory management to multiplayer interactions such as the chat function.

Steps to Reproduce:

1. Join a server and play normally for a period of time somewhere over an hour.

2. As you interact with the world, anything from placing a structure to gathering a resource, keep an eye out if you start failing to complete the interaction.

3. Check chat, inventory, equipment, crafting, etc. to see if anything is still functional.

4. Disconnect and rejoin server, the issue should be fixed for the time being.

P.S. Sorry if this isn't a very consistent way to reproduce the bug, it seemed to happen out of nowhere for me, but at least an hour of normal, uninterrupted gameplay passed between me joining the server and the bug occurring. I was picking berries one moment and then suddenly one of the bushes I picked wouldn't let me take anything from it, and most of my interactivity was frozen, barring movement.

Link to comment
Share on other sites

Latency can sometimes affect only certain parts and cause a desync, but this is definitely odd looking indeed. Does it still happen after the patch? 


Haven't had a chance to play since last night but I will update on this when I can if it reoccurs, until then if anybody else has experienced a similar issue this'll be a good place to document it. I also have some video of both occurrences which I'll post here soon is available below!


Don't Starve Together Bug Report - Disabled Interactions

Link to comment
Share on other sites

Just a little update to this issue, it occurred again, except this time I was in ghost form, and in addition to not being able to interact with any objects, I was also stuck moving diagonally up and left. Because of this I'm imagining a desync issue is more likely, where the game is maintaining a previous state and my character is simply taking in the last input it received, for some reason that input being frozen to one particular moment, preventing me from chatting or interacting or moving or really anything else.


Don't Starve Together Bug Report - Frozen Movement & Interactions as a Ghost

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.