Jump to content

Solved: Game repeatedly auto-pauses, need help diagnosing


Recommended Posts

I'm starting this in the general discussion section, since I don't have enough info to file a bug report yet.

Lately when I've been playing, every few seconds, the game will pause itself. I'll hit the spacebar to un-pause, it'll go for a few more seconds, and then pause again.

I had initially thought there was a problem with my keyboard, but that doesn't seem to be the case because ONI is the only program affected. And it also happens regardless of whether I'm using the laptop keyboard (almost never) or my bluetooth expanded keyboard (normal case).

It has also never caused the game to un-pause -- only pausing.

The amount of time between pauses varies. Sometimes it happens immediately after un-pausing.

Sometimes it seems to happen right after making a change to one of the conduit networks, i.e. re-routing some pipes.

It sometimes happens even if my hands are not on the keyboard, i.e. I'm just watching dupes work.

Why has this only started happening in the last few weeks? The one thing I can think of is that I recently went back and started playing at a higher difficulty level, starting with the larger Spaced Out maps. Right now I'm on the forest worldgen, so the central planetoid is huge. But I'm only about 150 cycles in.

This is now at the point where it's annoying enough to make me stop playing.

Has anyone else experienced this or is it just me? Does anyone have any ideas about what might be the cause?

I'm on a 2023 M2 MacBook Pro so I've got plenty of power. I generally play with lots of QoL mods, most notably including Fast Track.

Any thoughts about what I might try next? I could try disabling Fast Track to see if that's related, but I won't make it to cycle 1000 without it.

Edited by meekay
Link to comment
Share on other sites

The first step to troubleshooting this (and you really can't file a bug report until you do) will have to be to disable all your mods and check to see if the pausing still happens.  If it stops then you can slowly enable your mods and see which one causes it to start again.  If it doesn't then at least you have ruled out mods as a culprit.  It's a boring process, but I'm afraid it will have to be done.

Best of luck!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
  • Create New...