Jump to content

Mods not working: workshop-######## kind of problem.

Recommended Posts


I rebooted my computer recently and went to reinstall the game. However, some of my mods show a problem where they appear labeled as "workshop-#######". All my client mods are fine and working, only server mods have this issue. I have followed different instructions I found in the internet to solve the problem but nothing worked. This is how the mods appear:



Here are a couple things I tried (I may be forgetting something tho):


  • Unsubscribe and resubscribe to mods;
  • Reinstall the game;
  • Check integrity of game files;
  • Went to delete the mod files in C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods, but there are no files associated to the broken mods. All the files in the mod folders are related to mods that are working;
  • Tried to unsubscribe all mods then unistall the game and proceed to delete all DST files I could find and after that reinstall the game;
  • Copy the files in C:\Program Files (x86)\Steam\steamapps\Workshop\Content\322330 into C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods.
  • Copy the files as above and then delete the folder C:\Program Files (x86)\Steam\steamapps\Workshop\Content\322330 (also tried a variant in which I renamed the folders to what appears to be the "standard" for mods: workshop-######).
  • Copy the files as above and then delete the folder C:\Program Files (x86)\Steam\steamapps\Workshop\Content\322330 after unsubscribing all mods.
  • Tried everything single thing described above after reinstalling the game.


If I copy the files from C:\Program Files (x86)\Steam\steamapps\Workshop\Content\322330 into C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\mods, the mods tab in game become


So there is an "apparently good" copy of the mods but also a broken one. It still don't let me join a game.


If then I proceed to delete the folder C:\Program Files (x86)\Steam\steamapps\Workshop\Content\322330, the tab becomes this:


The "broken copies" disappear, however, I still can not join games as the following message appears:




This happens for every game I try to join, so it could not be that everyone hosting a game has unupdated mods. In addition, I have unsubscribed and inscribed again to mods many times (including reinstalling the game), so it too couldn't be that I have old version mods.



I hope someone can provide some guidance or ideas for me to try. Something I didn't try yet.


Thank you very much.


Link to comment
Share on other sites

On 6/9/2023 at 7:44 AM, Captain_Rage said:

Try to join a game without any mods. Use the filter in the server browser to get a list of servers running without mods.

I am able to join vanilla games. I am also able to join games using client mods and no server mods. The problem arises when there is some server mod involved.

Thank you.

Link to comment
Share on other sites

Make sure to delete the cache files of the mods, along with any folder. Such files might remain after uninstalling the game or unsubscribing to the mods and it means there are still settings and information pertaining to those mods lurking in the files.

One bet would be to uninstall the game, just to make sure, then browse C:\Program Files (x86)\Steam\steamapps\common\Don't Starve Together\ and delete any remaining files, or even the whole folder. The same goes for workshop content (not sure where that folder is). Reinstall afterwards.


Here people troubleshot a similar / the same problem and found two solutions:


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...