Jump to content

Dedicated Server Mods Update Question

Recommended Posts

Hi, I don't know if I can get the answer I want here, but I still hope someone can answer my confusion(about Dedicated Server Mods Update)

I am setting up on a windows cloud server, this is my configuration

system name:Microsoft Windows Server 2012 R2 Datacenter
System version number:6.3.9600
cpu:AMD EPYC7K62 48-Core Processor,2595Mhz
disk space:100G

】In terms of cloud storage, I think it meets the official configuration requirements

I describe a problem with cloud Dedicated Server mod updates:

I follow the official top “Dedicated Server Quick Setup Guide - Windows”to set up my dedicated server,But I forgot to set the my mods before opening the server(The server is up and running ,It was after entering the game and playing for a while that I found out that there is no mod:wilson_cry:

I have summed up all the methods in the forum into 2 kinds:

method one:Revise ServerModSetup("1216718131") inside "\mods\dedicated_server_mods_setup.lua" ------ Enter the game after restarting and find that it is invalid

method two:Recreate the modules in the local server and upload them to the dedicated server ------ Enter the game after restarting and find that it is invalid

So,The mod file after the server I created locally is overwritten on my dedicated server  ------ Enter the game after restarting and find that it is invalid

So I tried to put “\\Documents\Klei\DoNotStarveTogether\MyDediServer\Master\”file inside  modoverrides.lua and leveldataoverride.lua cover ,Glad it worked after restarting the server

I am here "\bin\scripts\launch_preconfigured_servers.bat" After starting and successfully entering the game, fortunately, the mod can be used normally,But I wanted to add a new module later and found that the previous method didn't work

I have no idea "dontstarve_dedicated_server_nullrenderer.exe" is it updated (The mod in the mod folder was deleted by me,Configured “modoverrides.lua”The mod file can be downloaded normally , But the mod information cannot be found in the game)

I put the running log that I think is important here,Hope someone can answer my confusionserver_log.txtserver_log_2023-04-30-17-20-04.txtworkshop_log.txt


------The above is google translate

===================2023/5/1=========== New_Log

Now there is a new problem, I delete all steamcmd items (including games and "C:\Users\Administrator\Documents\Klei"); reinstall
I use the command "app_update 343050 validate" to install my Don't Starve Together Dedicated Server


This is where my game saves are stored


The first time you install and run without mods, you can enter the game, and it will appear when you use the update command for the second time “DoNotStarveTogether_EasyConfigCaves”,“DoNotStarveTogether_EasyConfigOverworld”;as well as “C:\new_steam\steamapps\common\Don't Starve Together Dedicated Server”,‘ugc_mods’folder

Why every time you use “app_update 343050 validate”Will overwrite my original setting parameters,makes me have to write again after every update;


This is the compressed package of all my logs, if you can’t open it, please use “bandizip”




cloud_log.txt configstore_log.txt connection_log.txt connection_log_10999.txt connection_log_11000.txt connection_log_11001.txt content_log.txt server_log.txt server_log_2023-05-01-01-10-40.txt server_log_2023-05-01-01-17-06.txt server_log_2023-05-01-08-07-30.txt server_log_2023-05-01-08-31-31.txt server_log_2023-05-01-08-59-26.txt server_log_2023-05-01-09-19-15.txt systemmanager.txt workshop_log.txt

Link to comment
Share on other sites

Method one is the correct one, and should be used if possible. I did set up a guide a while back, which still works. You can check if you've configured everything properly in the dedicated_server_mods_setup.lua.


In the workshop_log the message

[AppID 322330] Updating workshop item details failed with Access Denied

pops up a few times. This might be related to either file system permissions in the mod directory (maybe you copied the mods there with higher privileges than the server user has/is using, so the server can't access/modify them), or your Antivirus (or even the built in one) block the access for whatever reason.

This somewhat gets confirmed by the message

DelDirectory [../mods/workshop-780009141] 2: FAILED

from the server_log_2023..., which indicates that the server really can't modify the directories there.

Link to comment
Share on other sites

3 hours ago, Daniel86268 said:

方法一是正确的方法,应尽可能使用。我前一段时间确实设置了一个指南,它仍然有效。您可以检查是否已在 dedicated_server_mods_setup.lua 中正确配置所有内容。


在 workshop_log 消息中

弹出几次。这可能与 mod 目录中的文件系统权限有关(也许您以比服务器用户拥有/正在使用的权限更高的权限复制了 mod,因此服务器无法访问/修改它们),或者您的防病毒软件(甚至内置的)出于任何原因阻止访问。


来自 server_log_2023...,这表明服务器确实无法修改那里的目录。

Thank you for your method,But I have tried all the methods you mentioned, and I have also considered whether it is caused by insufficient system permissions;This server is a pure system without any antivirus defense

Here is my mod config filededicated_server_mods_setup.lua启动DSTServers.bat启动DSTServers.bat

The commented out statement is to verify one of my conjectures,Check if updating the game is the reason why my mod fails to load;

The above operations are performed under the administrator user;

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...