Jump to content

My custom sounds aren't following in-game volume settings


Recommended Posts

Heyo, I've had custom sounds in my mod for a while now, but I seem to have overlooked that all of my sounds just seem to ignore the players own volume settings, even playing when the game is supposedly muted, along with looped sounds playing while the game paused (eg. autopause)

Not really sure what info to give, here's a screenshot of one my sounds in FMOD, all I'm doing to call it is a simple

inst.SoundEmitter:PlaySound("SOUNDPATH", "SOUNDNAME") -- Don't worry I have proper sound paths and names in my code

image.thumb.png.f57799990d1707f37c5e09c112fde7c5.png

Link to comment
Share on other sites

@TheSkylarr

From my understanding of it, the game uses mixing channels to denote the volume intensities of things.

From mixes.lua these are the FMOD categories you should use for audio to let the game know what volume they should be set at:

local amb = "set_ambience/ambience"
local cloud = "set_ambience/cloud"
local music = "set_music/soundtrack"
local voice = "set_sfx/voice"
local movement ="set_sfx/movement"
local creature ="set_sfx/creature"
local player ="set_sfx/player"
local HUD ="set_sfx/HUD"
local sfx ="set_sfx/sfx"
local slurp ="set_sfx/everything_else_muted"

I'm not familiar enough with the FMOD tool to know how you go about setting these categories.

  • Like 3
  • Thanks 1
Link to comment
Share on other sites

4 hours ago, CarlZalph said:

@TheSkylarr

From my understanding of it, the game uses mixing channels to denote the volume intensities of things.

From mixes.lua these are the FMOD categories you should use for audio to let the game know what volume they should be set at:


local amb = "set_ambience/ambience"
local cloud = "set_ambience/cloud"
local music = "set_music/soundtrack"
local voice = "set_sfx/voice"
local movement ="set_sfx/movement"
local creature ="set_sfx/creature"
local player ="set_sfx/player"
local HUD ="set_sfx/HUD"
local sfx ="set_sfx/sfx"
local slurp ="set_sfx/everything_else_muted"

I'm not familiar enough with the FMOD tool to know how you go about setting these categories.

Ah, I see. I went into the categories tab in FMOD and set up the structure like this

image.png.b85fe07de406983351f9a82c15d6d9e7.png

And it worked like a charm! Thanks for the help!

  • Thanks 1
  • Sanity 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...