Jump to content

All mods disabled since Forgotten Knowledge Update


Recommended Posts

The Forgotten Knowedge Update disabled every mod on current savegames. I read there was a hotfix, but my game is up to date and mods are still disabled. Its very difficult for me to enable every mod again because there are ~120 from which ~70 were enabled on my current savegame (which is on day 400+).

If it is not possible to fix this, is there a way to figure out which ones were enabled ?

Link to comment
Share on other sites

try to run this command

ShardSaveGameIndex:RerunSlotConversion(slot)

slot is for number of your world cluster, for example for Cluster_1 it will be 1
Cluster number can be found here
image.thumb.png.39dea9aaa95586d5a571f682f5ff4579.png
Be sure to back up your world before that in case something will go wrong.

Link to comment
Share on other sites

Thanks, mate! This restored my Worlds setting, so the mods are enabled again.

But this lead to another issue. After loading the world, a message told me the world will restart to complete retrofitting.

After restarting, I instantly loose connection to the server. I dont know if this issue is related to this topic.

But I need help. Im really worried about my save >.<

Link to comment
Share on other sites

53 minutes ago, Zeitgeist60 said:

After restarting, I instantly loose connection to the server. I dont know if this issue is related to this topic.

What error did you get? Can you provide a log?
Server log is usually located in this path

C:\Users\user_name\Documents\Klei\DoNotStarveTogether\Cluster_X\Master\server.log.txt

or

C:\Users\user_name\Documents\Klei\DoNotStarveTogether\Cluster_X\Master\backup\server_log\server_log_YEAR-MONTH-DAY-HOURS-MINUTES-SECONDS

DAY and MONTH can be swapped depending on the date on your computer.

Link to comment
Share on other sites

Well, a few hotfixes later things look different. Sorry for reply again so late I had no time left yesterday.

There is no more retrofitting process when loading my savegame and so there is no disconnection from the server anymore.

I dont know if this is how it should be, but I'm happy :)

Thanks for your help, man.

 

Screenshot (2).png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...