Sign in to follow this  
GuilhermeT

[UPDATE: More Infos] Dedicated Server just starts in Beta

Recommended Posts

GuilhermeT    36

Hi there,

I'm trying to set up a dedicated server again, but I'm not able to open it out of the Beta

When I open the Server, it keeps creating a new folder called "DoNotStarveTogetherReturnOfThemBeta"

My Update Servers File:

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 validate +quit
Spoiler

image.thumb.png.b7b2b5c1c1ca54c7e9b507499681cbdf.png

I have no idea how to solve this. Both my game and the codes aren't in the beta

Thanks for the help

Edited by GuilhermeT

Share this post


Link to post
Share on other sites
GuilhermeT    36

I'm wondering if this already happened to anyone, so just to be more clear

I generated my config file from ingame account button, so my Documents/Klei folder is just like this:

Spoiler

image.thumb.png.dddf7fc1607cc6d5b1c055d73965419b.png

My DoNotStarveTogether folder and MyDediServer folder

Spoiler

image.thumb.png.ebbcd4b2b4ccbeb80dfe51226412d94b.png

Now, if I run the Server (StartDSTServers) I got this error:

cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
start dontstarve_dedicated_server_nullrenderer -cluster MyDediServer -shard Master
start dontstarve_dedicated_server_nullrenderer -cluster MyDediServer -shard Caves
Spoiler

image.thumb.png.65866efba46a319eeb22afa42be143d7.png

Full Master Log:

Spoiler

[00:00:00]: 
System Memory:
	Memory Load: 69%
	Available Physical Memory: 2493m/8058m
	Available Page File: 8681m/16250m
	Available Virtual Memory: 4005m/4095m
	Available Extended Virtual Memory: 0m
[00:00:00]: 
Process Memory:
	Peak Working Set Size: 11m
	Working Set Size: 11m
	Quota Peak Page Pool Usage: 168k
	Quota Page Pool Usage: 168k
	Quota Peak Non Paged Pool Usage:16k
	Quota Non Paged Pool Usage: 15k
	Page File Usage: 3m
	Peak Page File Usage: 3m
[00:00:00]: PersistRootStorage is now APP:Klei//DoNotStarveTogetherReturnOfThemBeta/MyDediServer/Master/ 
[00:00:00]: Starting Up
[00:00:00]: Version: 382151
[00:00:00]: Current time: Sat Nov 30 18:21:03 2019

[00:00:00]: Don't Starve Together: 382151 WIN32
[00:00:00]: Build Date: 4884
[00:00:00]: Mode: 32-bit
[00:00:00]: Parsing command line
[00:00:00]: Command Line Arguments: -cluster MyDediServer -shard Master 
[00:00:00]: Initializing distribution platform
[00:00:00]: Initializing Minidump handler
[00:00:00]: ....Done
[00:00:00]: ....Done
[00:00:00]: Fixing DPI
[00:00:00]: ...Done
[00:00:00]: THREAD - started 'GAClient' (2872)
[00:00:00]: CurlRequestManager::ClientThread::Main()
[00:00:00]: Mounting file system databundles/klump.zip successful.
[00:00:00]: Mounting file system databundles/shaders.zip successful.
[00:00:00]: Mounting file system databundles/fonts.zip successful.
[00:00:00]: Mounting file system databundles/anim_dynamic.zip successful.
[00:00:00]: Mounting file system databundles/bigportraits.zip successful.
[00:00:00]: Mounting file system databundles/images.zip successful.
[00:00:00]: Mounting file system databundles/scripts.zip successful.
[00:00:00]: ProfileIndex:23.08
[00:00:00]: [Connect] PendingConnection::Reset(true)
[00:00:00]: THREAD - started 'Ping Job Thread' (10580)
[00:00:00]: Platform: 1
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Network tick rate: U=15(2), D=0
[00:00:00]: Error trying to change cluster setting (NETWORK->cluster_intention) from '' to 'cooperative'
[00:00:00]: Authorized application c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin\dontstarve_dedicated_server_nullrenderer.exe is enabled in the firewall.
[00:00:00]: WindowsFirewall - Application already authorized
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogetherReturnOfThemBeta/MyDediServer/blocklist.txt (Failure)
[00:00:00]: THREAD - started 'StreamInput' (7076)
[00:00:00]: OnLoadPermissionList: APP:Klei//DoNotStarveTogetherReturnOfThemBeta/MyDediServer/adminlist.txt (Failure)
[00:00:00]: OnLoadUserIdList: APP:Klei//DoNotStarveTogetherReturnOfThemBeta/MyDediServer/whitelist.txt (Failure)
[00:00:01]: HardwareStats:
  OS                        
    name                      Microsoft Windows 10 Home Single Language
    version                   10.0.18362
    architecture              64 bits
    platformSpecific          SP 0.0
  CPU                       
    numCores                  2
    features                  SSE,SSE2,SSE3,SSSE3,SSE41,SSE42,AVX
    name                      Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz
    manufacturer              GenuineIntel
    clockSpeed                2401
  RAM                       
    megsOfRam                 8192
  GPU                       
    name                      Intel(R) HD Graphics 520
    driverDate                20170201000000.000000-000
    megsOfRam                 1024
    refreshRate               60
    videoModeDescription      1366 x 768 x 4294967296 cores
    driverVersion             21.20.16.4599

[00:00:01]: cGame::InitializeOnMainThread
[00:00:01]: Renderer initialize: Okay
[00:00:01]: AnimManager initialize: Okay
[00:00:01]: Buffers initialize: Okay
[00:00:01]: cDontStarveGame::DoGameSpecificInitialize()
[00:00:01]: GameSpecific initialize: Okay
[00:00:01]: cGame::StartPlaying
[00:00:01]: LOADING LUA
[00:00:01]: DoLuaFile scripts/main.lua
[00:00:01]: DoLuaFile loading buffer scripts/main.lua
[00:00:02]:   taskgrouplist:	default	Together	
[00:00:02]:   taskgrouplist:	classic	Classic	
[00:00:02]:   taskgrouplist:	cave_default	Underground	
[00:00:02]:   taskgrouplist:	lavaarena_taskset	The Forge	
[00:00:02]:   taskgrouplist:	quagmire_taskset	The Gorge	
[00:00:02]: running main.lua
	
[00:00:02]: Could not load modindex	
[00:00:02]: ModIndex: Beginning normal load sequence for dedicated server.
	
[00:00:02]: DownloadMods(0)
[00:00:02]: Event data unavailable: lavaarena_event_server/lavaarena_achievement_quest_defs
[00:00:06]: LOADING LUA SUCCESS
[00:00:07]: PlayerDeaths could not load morgue	
[00:00:07]: PlayerHistory could not load player_history_staging	
[00:00:07]: ServerPreferences could not load server_preferences	
[00:00:07]: bloom_enabled	false	
[00:00:07]: Could not load saveindex	
[00:00:07]: OnFilesLoaded()	
[00:00:07]: OnUpdatePurchaseStateComplete	
[00:00:07]: Klump load on boot started.	
[00:00:07]: Klump files loaded: 	0	
[00:00:10]: 	Load FE	
[00:00:14]: 	Load FE: done	
[00:00:14]: THREAD - started 'FilesExistAsyncThread' (8760)
[00:00:14]: FilesExistAsyncThread started (13914 files)...
[00:00:14]: Check for write access: TRUE
[00:00:14]: Check for read access: TRUE
[00:00:14]: ModIndex: Load sequence finished successfully.	
[00:00:14]: Reset() returning
[00:00:15]: [200] Account Failed (6): "E_INVALID_TOKEN"
[00:00:15]: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[00:00:15]: !!!! Your Server Will Not Start !!!!
[00:00:15]: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[00:00:15]: No auth token could be found.
[00:00:15]: To generate a cluster_token you must
[00:00:15]: open the console from a logged-in game
[00:00:15]: client with the tilda key (~ / ù) and type:
[00:00:15]: TheNet:GenerateClusterToken()
[00:00:15]: This will create 'cluster_token.txt' in
[00:00:15]: your client settings directory. Copy this
[00:00:15]: into your cluster settings directory.
[00:00:15]: [Connect] PendingConnection::Reset(true)
[00:00:58]: Collecting garbage...
[00:00:58]: lua_gc took 0.05 seconds
[00:00:58]: ~ShardLuaProxy()
[00:00:58]: ~cEventLeaderboardProxy()
[00:00:58]: ~ItemServerLuaProxy()
[00:00:58]: ~InventoryLuaProxy()
[00:00:58]: ~NetworkLuaProxy()
[00:00:58]: ~SimLuaProxy()
[00:00:58]: FilesExistAsyncThread aborted.
[00:00:58]: ... FilesExistAsyncThread complete
[00:00:58]: lua_close took 0.10 seconds
[00:00:58]: Orphaned unnamed resource. This resource must have used Add( resource ) to insert itself into the manager. 
[00:00:58]: CurlRequestManager::ClientThread::Main() complete
[00:00:58]: HttpClient2 discarded 0 callbacks.
[00:00:58]: Shutting down

 

When this folder is created, The file cluster_token doesn't exist. If I copy and paste the whole folder MyDediServer from DoNotStarveTogether to DoNotStarveTogetherReturnOfThemBeta then the server will run without problems, because now there is a cluster_token...

I think this line is important, It creates a folder in Beta, but I don't know what "PersistRootStorage" means exactly or how to avoid that

[00:00:00]: PersistRootStorage is now APP:Klei//DoNotStarveTogetherReturnOfThemBeta/MyDediServer/Master/ 

I already tried delete the folder "C:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server" and downloaded it again, but no sucess.

I was a long time away, without create any dedicated server, it was even the old method, but I don't know if there's relationship

 

UpdateServers.bat:

Spoiler

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 validate +quit

 

 

Share this post


Link to post
Share on other sites
Daniel86268    370

Everything seems correct so far. I assume it might not opt out of the beta with the update script, because the beta already had a higher build number than the current stable build.

Just delete the server files inside

c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server

(but keep the mods folder, or at least your dedicated_server_mods_setup.lua in case you have any mods installed.)

Afterwards run the update script again, and it should be the stable build.

Edited by Daniel86268
Typo

Share this post


Link to post
Share on other sites
GuilhermeT    36
On 01/12/2019 at 4:18 PM, Daniel86268 said:

Everything seems correct so far. I assume it might not opt out of the beta with the update script, because the beta already had a higher build number than the current stable build.

Just delete the server files inside


c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server

(but keep the mods folder, or at least your dedicated_server_mods_setup.lua in case you have any mods installed.)

Afterwards run the update script again, and it should be the stable build.

 

Hi,

I did what you said, but again with no sucess... Then I decided to do delete the whole "steamcmd" folder, and just copied it from another pc (Who was working fine), now it worked. (should have done that before)

I thank you for the reply, not sure what hapenned but something related to steamcmd.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this