Jump to content

My friend just turned into a Wilson...


Recommended Posts

I played with my friend on a server and everything was normal until today. It was around day 51.
Today I had some problems with my server anyway. First, I couldn't launch the server and an error showed up - "Dedicated server failed to start"
I just restarted the game and the problem was solved, I joined the server and I couldn't see my character skin (it was default), and when I entered caves there was an error again, something about being unable to reach Klei servers. I verified integrity of game files and both problems were gone.
But some time later, my friend rejoined the server, and when he joined again, character selecting screen popped up for him.
He chose Wurt (as he was playing Wurt before), but he spawned as default Wilson, without any clothes.
We tried everything, we restarted the game, we both verified integrity of game files, but nothing helped.
He also lost all the items he had in his inventory as Wurt.

How could that happen?

Link to comment
Share on other sites

25 minutes ago, bizziboi said:

My question was mostly to see if it was OSX as the new OSX has imposed some new security restrictions, and I wondered if it could be related.

Nope, we both use Windows. So does that mean it's an unknown glitch?

Guess we'll have to start a new run or use mods to switch back then, but i hope it can be somehow fixed to ensure that it won't happen in the future.

Link to comment
Share on other sites

  • Developer

It seems because you were temporarily unable to connect to the Klei server.

When the Klei server can not be contacted it fails the Wurt ownership check, forcing it into a Wilson. It seems this also forced the game to despawn his Wurt character as it could hold character specific items, which could explain why his inventory was gone.

Link to comment
Share on other sites

Hm, that's still odd, because I had problems with the Klei servers, and my skin wasn't present, but everything was fine for my friend. After I verified integrity of game files the problem seemed to be fixed, and after that my friend rejoined several times (I wasn't restarting the server anymore) and everything was fine.

It was some time later when this occured.

But that sounds plausible, thanks for helping anyway.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...