Jump to content

character mod won't activate


Recommended Posts

so, this is my first time modding, I just want to put one of my personal characters as an option for myself to play (meaning I'm not planning on putting this on steam.)

I've been following this tutorial: https://www.youtube.com/watch?v=OpFxjbpyJes

and using this mod template: https://forums.kleientertainment.com/files/file/950-extended-sample-character/

I've done everything in the tutorial and went to test it before tackling the art for the puppet itself. I just want to focus on getting a character running, I'll learn how to add buffs and do more later.

My problem is that I'll get in DST, have the mod show up in my list, click on activate and it makes the game reload itself. I re-login, go to start a world and my character isn't in the character select menu. I went to check my mods and the one I had made wasn't active.

so far I've tried restarting the game, I've tried rewatching the tutorial fully, I've tried finding someone with a similar problem and made sure my mod was in the correct folder. I haven't tried putting it on the steam workshop as this is a personal mod I'd rather not have on there but I'd be surprised if it would work. if it failed the running test, I don't think it would magically work just because it's on steam but I'm also a newbie so I have no clue.

 

any form of help is appreciated but I'm unfortunately a very visual person and get confused about things like this. If you guys have any video recommendations or guides or just tips, I'd love to hear them! anything is appreciated ^^

 

thank you and have a good day!

 

 

 

Link to comment
Share on other sites

Visual person or not, you're stepping into some coding, and there's no way around a bit of studying to not constantly hit pitfalls like this.

Take a look at my newcomer post. Most of it will be relevant to you, but right now, you need to know about debugging your mod, specifically where to find the logs which tell you what's going wrong with your mod. Since you're not even getting to enter the server, you'll probably be finding your error in the client log.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...