Sign in to follow this  

Unequipping Atmo Suit doesn't clear Soiled Suit Debuff


sirnumbskull
  • Branch: Live Branch Version: Windows Pending

If a dupe soils their suit and then unequips said suit they can't remove their soiled suit debuff unless they re-equip a suit and use an atmo suit station.  I tried building a shower, but that wouldn't remove it either; only building an atmo suit station and checkpoint, delivering their suits, and then forcing them past the checkpoint so they equip/unequip their suits will remove it


Steps to Reproduce

Equip atmo suits.  Fly in rocket ship to another planet.  Wait for dupes to soil their suits.  Unequip said suits.  Dupes have permanent debuff until you build an atmo suit checkpoint/station, deliver a suit, and have the dupe walk past the checkpoint.  

SpaceJunk Cycle 112.sav

Sign in to follow this  


User Feedback


....

Unequip suit, then re-equip and unequip again solved it for me without building atmo suit station

I managed to get out of this mess...

Spoiler

363908955_C247Nisbetthere_100.thumb.jpg.7c56be599e24e4993f834a39cb0490db.jpg

But it's not only atmo suits. Snazzy suit doesn't register it's decor until reloading the game

Spoiler

 

Equiping snazzy suit. Save game.

1739709433_outfitsnazzy.thumb.png.f74cd9815060b23cd2b14305ce9e2b71.png

Reload

93882002_outfitsnazzyequipreload.thumb.png.fdf0ac3ea30d2b788bec16660b2be691.png

 

I don't know if save-reload also solves soiled suit debuff

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now