Jump to content

Steam achievements drop in debug mode

  • Branch: Live Branch Version: OSX Pending

I wanted to mess with ranch designs in a separate map, and to reduce the strain of simulation, I enabled the minibase - spaced out mod.

In the menu I enabled debug by typing KLEIPLAY, and went on to create the modded map. The map generated immediately, the game started with debug enabled (Ctrl+F4, worked, I was able to instantly dig and skill the dupes up), and yet I was awarded 2 steam achievements - "Pulling Back the Veil" and "Cluster Conquest".

I'm not sure if it makes a difference, but this happened with the game running through family sharing (which is why they unlocked in steam too) - so that account now has 2 somewhat rare achievements, and nothing else :D 

Idyllic Lab.zip

Player-prev.log Player.log

Steps to Reproduce
  1. Enable minibase mod (or something similar which by design grants achievement immediately after generating the map).
  2. Enable debug mode in menu.
  3. Create a new map.
  4. Check if you get steam achievements

User Feedback

The only other mod (that I know of) that automatically grants an achievement is Single Asteroid Clusters and it says so in the description. Either way, debug mode should disable all achievements (unless of course you have a mod that enables them again already active)

Share this comment

Link to comment
Share on other sites

KleiPlay doesn't activates debug mode, it only allows it. Achievements are disabled by using it - like using Alt+Q, doing something while Ctrl+F4 mode is enabled, or by using BackSpace (which reveals map).

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...