"RtlLookupFunctionEntry returned NULL function" with RivaTuner

  • Branch: Preview Branch Version: Steam Pending

I've got it solved, but I'm describing the issue so that one might find the solution, having a similar problem.

I used to have this problem while I was participating in Steam Beta. Game was crashing on startup. Log stated:

<RI> Initializing input.

<RI> Input initialized.

desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0
========== OUTPUTING STACK TRACE ==================
RtlLookupFunctionEntry returned NULL function.

Switching to Steam production build fixed the issue that time (might be only correlation). But now the problem came back and it seems I worked out what's the real cause.

I use RivaTuner and MSI Afterburner for OSD. When I close RivaTuner, the game starts without any issues. I checked which setting is causing it. If you turn off "Custom Direct3D support", the game crashes. The issue might affect more software like that.


Steps to Reproduce
- install Riva Tuner - turn off "Custom Direct3D support" - run the client

User Feedback

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now