Pacu do not lay eggs


SakuraKoi
  • Branch: Live Branch Version: Windows Fixed

To put it simple: Even though Pacu visibly reach 100% reproduction, the number resets to 0% without an egg being laid and without reason, the NoPacuEgg.sav should show it well. The Pacu there is also be able to lay another egg before dying but it won't.

A bit more I observed and would like to note: First, I see only wild Pacu die without leaving eggs, then I get to a Pacu in time, feed&tame it yet even though it should have laid many eggs by now, it did never lay even one.

I'm not sure what is wrong and it might be no real bug but if the habitat is too small, and so would be pretty much all natural spawn points in return, then it is not shown (and should be changed anyway). Or if it is because it is Elderly... that's NG either (I know for sure that the value was @30% when just tamed).


Steps to Reproduce
0: Observe wild Pacu go extinct in the natural habitat 1: Quickly tame a wild Pacu by feeding it 2: Wait for the Reproduction value reaching 100% (<=the .sav is @99%) 3: Watch it reset to 0% with nothing more happening.


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Changed Status to Fixed

You weren't doing anything wrong.  There was a very obscure bug, which would only happen if the tile at the very bottom left of your entire map was magma, it would cause all Pacu eggs to be laid outside of the map and destroyed, instead of by the Pacu that laid them.

You won the map generation lottery on this one :)  Thanks for including your save game, it was really helpful in tracking this down.

The bug will be fixed in the next update.

  • Thanks 2
  • Haha 2

Share this comment


Link to comment
Share on other sites
7 minutes ago, Brook said:

You weren't doing anything wrong.

Well, to be perfectly honest... I did switch DrawWorldBorder: true to false which sure explains why no one else encountered it yet, besides maybe those other very few who actually found&use my mod which removes/replaces Neutronium.

I would have never thought that this or any other of my little modifications (removing the meteor seasons parameters, a bit of extra food and new POIs) would result in this. I did consider it but thought "nah, how could it possibly~" so I do feel a bit sorry about not mentioning it.

Anyway, thank you very much.

  • Haha 2

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now