Sign in to follow this  

ONI not loading beyond KLEI Logo - 2,000 Hours - Occurred after DLC BETA Introduced


TwitchRouniee
  • Branch: Live Branch Version: Windows Pending

I've had few issues with ONI over the years and 2000 hours later, as of sometime last week, I'm no longer able to load the game past the KLEI logo. I'm thoroughly disappointed as I had planned on getting the DLC.

I've never had this issue before the most recent update that included the test branch for the DLC (I had not downloaded the beta). Despite being on vanilla, I still cannot access the game. I've uninstalled and reinstalled ONI multiple times with no luck.


Steps to Reproduce

Open the game

Sign in to follow this  


User Feedback


Tenho esse mesmo problema. 
Depois da atualização do dia 26/11 não acesso mais o jogo. Ele para no logotipo da KLEI com a seguinte mensagem: 
Unity 2019.4.14f1_4037e52648cd
Após isso o jogo fecha.

WhatsApp Image 2020-12-02 at 15.37.02.jpeg

Share this comment


Link to comment
Share on other sites

After lastest update that deployed to steam earlier today, the same is now happeneing for me.  I can't get past Klei loading screen without a crash.  I verified file integrity and also uninstalled and reinstalled.  

ONI Crash.png

Edited by Tremblore
missing info

Share this comment


Link to comment
Share on other sites

Hi, we're still trying to figure out a reliable solution for clearing the startup crash. It seems that some old files from the DLC are getting stuck in the install folder. Some things to try:

  • Right-click ONI -> Properties -> Local Files -> Browse local files .... go into the OxygenNotIncluded_Data folder and delete StreamingAssets, then Properties -> Local Files -> Verify Integrity of Game Files
  • Uninstall and reinstall the game through steam
  • Browse to the local files as above, uninstall the game, after uninstall finishes delete any files that are left over in the SteamApps/common/OxygenNotIncluded folder, and then reinstall.

Please be careful when deleting files on your hard drive, and let us know if any of these solutions fixes the problem for you so we can share the information!

Edited by Ipsquiggle
edited with more potential solutions

Share this comment


Link to comment
Share on other sites
1 hour ago, Ipsquiggle said:

Some things to try:

  • Right-click ONI -> Properties -> Local Files -> Browse local files .... go into the OxygenNotIncluded_Data folder and delete StreamingAssets, then Properties -> Local Files -> Verify Integrity of Game Files
  • Uninstall and reinstall the game through steam
  • Browse to the local files as above, uninstall the game, after uninstall finishes delete any files that are left over in the SteamApps/common/OxygenNotIncluded folder, and then reinstall.

Please be careful when deleting files on your hard drive, and let us know if any of these solutions fixes the problem for you so we can share the information!

I tried all 3 of them and none worked. Even tried removing (macOS) ~/Library/Application Support/unity.Klei.Oxygen Not Included/ (after backing it up, as it includes my save) and it still didn't go past the Klei logo.

Share this comment


Link to comment
Share on other sites

Welp I just bought and installed the DLC. Now my game loads again.

That said, it's virtually frozen at the opening page. I don't know where to find the player log.

Untitled-1.png

Debug txt file attached

debug.log

Edited by TwitchRouniee

Share this comment


Link to comment
Share on other sites

Uninstalling, then deleting the entire Oxygen Not Included folder from steamapps/common fixed this for me. The saves seem to have been successfully migrated over as well (though I haven't yet bought the DLC, so I can't verify whether the DLC alpha saves still load.

Share this comment


Link to comment
Share on other sites
On 12/7/2020 at 3:47 PM, formovel said:

I have this same problem.
After the update on November 26, I no longer access the game. It stops at the KLEI logo with the following message:
Unity 2019.4.14f1_4037e52648cd
After that the game closes.

WhatsApp Image 2020-12-02 at 15.37.02.jpeg

 

Share this comment


Link to comment
Share on other sites
10 hours ago, Abdulijubjub said:

Uninstalling, then deleting the entire Oxygen Not Included folder from steamapps/common fixed this for me. The saves seem to have been successfully migrated over as well (though I haven't yet bought the DLC, so I can't verify whether the DLC alpha saves still load.

This is part of what I did when I uninstalled my game. No go.

That said, again, once I installed the DLC public beta, the game does load. The loading screen is absolutely locked with about 1 frame every 5 seconds. I can still get into a game if I'm extremely patient.

Hover over the 'new game', 'load game' until it brightens - about 30 seconds to a minute

Click - about 10 seconds to respond

Choose survival - Again takes about 10 seconds to respond

Once in the game, it runs normally.

 

--

It's not a hardware issue either. My PC is more than overkill for this game.

Share this comment


Link to comment
Share on other sites

I've been having almost the same problem, but I don't even make it to the Klei logo. I just get the dupe window and crash. No word and no solution. I'm not happy.

Share this comment


Link to comment
Share on other sites

Quick update - the issue is still very much so there. I've gotten used to sitting in the loading screen and main screen for a while as I patiently hover, click, repeat to get the game running.

Share this comment


Link to comment
Share on other sites
08.12.2020 о 20:34 Іпскіггле сказав:

Привіт, ми все ще намагаємось знайти надійні рішення для усунення аварійного завершення роботи. Здається, деякі старі файли з DLC закріплені в програмі встановлення. Деякі речі, які потрібні з використанням:

  • Клацніть правою кнопкою миші ONI -> Властивості -> Локальні файли -> Переглянути файли файлів .... перейдіть у папку OxygenNotIncluded_Data та видаліть StreamingAssets, потім Властивості -> Файли локалей -> Перевірка цілісності ігрових файлів
  • Виділіть і переінсталюйте гру за допомогою пари
  • Перейдіть до локальних файлів, як вище, видаліть гру, після встановлення блоків видаліть будь-які файли, що залишилися в SteamApps / загальний / OxygenNotIncluded папку , а потім переустановіть.

Будьте обережні, видаляючи файли на жорсткому диску, і повідомте нам, якщо будь-яке з цих рішень вирішіть проблему, щоб ми могли поділити інформацію!

Це не допомагає мені

Share this comment


Link to comment
Share on other sites

Hi everyone,

It seems that this is an issue with certain AMD graphics drivers and this version of Unity. We're working with Unity to find a solution to this issue. We hope this will be resolved soon, thanks for all the information you've provided us in the various threads and crash reports!

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now